The nextcloud client displays that all folders are synchronized but some are missing on the windows computer


Yesterday I upgraded Nextcloud from version 17.0.9 to version 18.0.10. A user reported a synchronization problem with some of his folders.

When he looks at his Nextcloud client he can see all the folders and that they are well synchronized:
Clipboard - 14 octobre 2020 14_40

But when he looks in his Windows explorer, only one folder appears:
Clipboard - 14 octobre 2020 14_41

Miscellaneous information:

  • Folders are present on the web interface
  • Nextcloud client version is
  • All conflicts have been resolved, the nextcloud icon is now green
  • The folder is in a folder created by the plugin “Group Folder”.
  • No error message in server logs
  • The problem is only present on one computer at the moment
  • The synchronization logs do return the information that the folders are downloaded, for example:
||Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek|INST_NEW|Down|1578673783|5e18a67763ac4|0|01501139oc189338b009|4||0|0|0||||
||Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/115.cfg -> Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/115.cfg|INST_RENAME|Down|1422540304|54ca3e31119a0|4889|00026949oc189338b009|4||0|0|0||||
||Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/379.cfg -> Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/379.cfg|INST_RENAME|Down|1472548032|def1789fc5089f9474c8b95b025f0afc|7432|00623837oc189338b009|4||0|0|0||||
||Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/V130_20161107_BAYONNE-379_Nerim.cfg -> Outsourcing Group Folder/Outsourcing/Routers/Configs Clients/Client/Draytek/379.cfg|INST_RENAME|Down|1478541479|e67912f02aec854ced64c07bc90b8c3c|7452|00773285oc189338b009|4||0|0|0||||

I would like to know some information:

  • How to identify the problem on Nextcloud clients to see if other folders are not synchronized?
  • How can I solve the problem?

did you tried “force sync now” from the Settings menu?

Yes of course, that was one of the first things I did.

most likely you have to re-sync the folder. Try uncheck and check this folder again.

I think the only way to find out if there are missing folders is to compare directories on NC (e.g. by using WebDAV mount) with the local directory. Some file managers like Total Commander have built-in directory compare/sync tool. By default it seems to be no persistent client log. but you can review the client log by pressing F12 - here you have select the option to persist the client log as well - but I’m not aware if this setting is persistent across reboots.

Maybe reviewing the log after triggering a re-sync gives you a hint…

Thanks for this information, I will try to uncheck and re-check the folder when I get the computer.

Concerning your solution, it can be done for one workstation, but when we have a lot of workstations to check the procedure is more complex.

I suppose not, but wouldn’t you have another way of checking on a larger scope?

Thank you for your answer!

The problem has been solved by unchecking and re-checking the folder.
I checked the logs but it doesn’t give us any more information.

Unfortunately it is a bit the simple solution. If someone has a solution to massively check if there are files and/or folders missing. I’m a taker!

Keep an eye on that, I don’t trust the client version 3. When I upgraded the client to 3, it lost four out of five syncs, and the last remaining one didn’t work properly. Even after I removed the remaining sync and recreated them all, folders were intermittently not syncing individual files between my desktop and laptop.

I gave up and uninstalled client version 3, and reinstalled 2.6.5. Everything has worked fine since then. I figure I’m gonna wait until 3.1 is released before trying it again.

1 Like

Indeed I had a lot of trouble adapting to this new version. In addition to synchronization problems. I’m not a fan of this new version.

I myself had problems with folders that were no longer checked. I’ll keep an eye on the synchronization.

Thank :slight_smile: