Text editor loses connection regularly

Nextcloud version (eg, 18.0.2): 19.04
Operating system and version (eg, Ubuntu 20.04): CentOS (shared hoster uberspace.de)
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing: If I edit markdown documents via the embedded web texteditor, it loses regularly the sync:

file could not be loaded. Please check your internet connection (retry)

This occurs right after a few minutes and I guess a tip faster if you are on a edit. This error occurs on different internet connections.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Open Files app on your cloud webinterface
  2. Click a textfile to edit
  3. Start writing to the opened file and wait till the above poppup message appears
  4. Click rety and note, that nothing will reload. So reload the whole page

The output of your Nextcloud log in Admin > Logging:

Info	files_versions	Expire: /todo-neu.md.v1604050096	
2020-10-31T14:46:45+0100
Info	files_versions	Expire: /todo-neu.md.v1604146048	
2020-10-31T14:46:45+0100
Info	files_versions	Expire: /todo-neu.md.v1604146364	
2020-10-31T14:46:45+0100
Info	files_versions	Expire: /todo-neu.md.v1604146489	
2020-10-31T14:46:45+0100
Info	files_versions	Expire: /todo-neu.md.v1604146882	
2020-10-31T14:46:45+0100
Info	files_versions	Mark to expire /todo-neu.md next version should be 1603975689 or smaller. (prevTimestamp: 1604062089; step: 86400	
2020-10-31T14:46:44+0100
Info	files_versions	Mark to expire /todo-neu.md next version should be 1604143669 or smaller. (prevTimestamp: 1604147269; step: 3600	
2020-10-31T14:46:44+0100
Info	files_versions	Mark to expire /todo-neu.md next version should be 1604143669 or smaller. (prevTimestamp: 1604147269; step: 3600	
2020-10-31T14:46:44+0100
Info	files_versions	Mark to expire /todo-neu.md next version should be 1604143669 or smaller. (prevTimestamp: 1604147269; step: 3600	
2020-10-31T14:46:44+0100
Info	files_versions	Mark to expire /todo-neu.md next version should be 1604143669 or smaller. (prevTimestamp: 1604147269; step: 3600	
2020-10-31T14:46:44+0100

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE
1 Like

I can confirm this issue. The editor becomes unusable

I’ve run into exactly the same problem.

This issue is that no cache has been set. The Nextcloud documentation indicates that setting a cache is not required. While this is true, the fact that no cache has been set means that the Text Editor application disconnects immediately once typing has stopped. The application attempts to perform a Save using the cache… but there is no cache… and so the application produces the error message and requests to be reconnected.

The solution to this problem is enabling a local cache using the instructions in the Nextcloud documentation:

https://docs.nextcloud.com/server/24/admin_manual/configuration_server/caching_configuration.html

After enabling the APCu and memcached utilities exactly as described above, the error message goes away and the text editor application runs quite smoothly.

1 Like