Text editor corrupting text file

I’m currently running version 25.0.3 of NextCloud.

I just tried editing a text file that was created under a previous version of NextCloud, most likely 25.0.2. The file contains a number of URLs that I’m saving. When I’ve tried opening the file via the web interface (using Vivalid on an Android tablet), it showed a bunch of web previews. And when I tried to edit the file, I couldn’t get the cursor to stay at the end of the file so I could append additional text. And the text editor end up screwing up the file when I tried to paste an additional URL into the file.

Has anyone else encountered this issue? Is there a fix/solution to the issue?

Also, how do I NOT get the web previews? I just want to create/have a plain, simple, ordinarily text file.

Have you tested it with another browser on Android?
Have you tested the Android App Nextcloud?
Why do you use a browser and not the app to access Nextcloud on Android?
Mostly it makes no sense to use a browser on Android/iOS.

There is also a Nextcloud app Plain text editor.

No, I didn’t try another browser. Yes, I also tried the Android App Nextcloud app with the same results.

Thank you, I’ll take a look at the Plain Text Editor when I’m back in the office.