Text comments cannot be inserted if they contain non-English characters using Collabora Online

Hi everybody.

When I try to insert a comment in an odt text file using Collabora Online, the comment is not inserted if it containing a non-english character such as German character “ö”, French/Catalan character “ç”, Spanish character “ñ”, etc. This happens independently from the language to which the text is set.

This problem is rather annoying as somebody may be writing a rather long comment and when the “save” button is pressed in order to insert the comment, the whole comment disappears instead of being inserted on the text side.

Please, can anybody confirm this is a bug?

I’m using Nextcloud 22.1.1 with Collabora Online 4.2.3 and Collabora Online - Built-in CODE Server (ARM64) 6.4.1303.

Thanks in advance.

Cheers

Hi,

What database are you using with your install?
I’ve seen this issue with MySQL/MariaDB when 4-byte character support is not enabled.

See: https://docs.nextcloud.com/server/stable/admin_manual/configuration_database/mysql_4byte_support.html

Let me know if this is the issue and if it helps.
-G

Hi @gibikha,
Thank you very much for your quick reply. I’ll have a look at it and then post results on this thread.

@gibikha, I have followed your proposal and enabled the 4-byte character support. Unfortunately this doesn’t solve the issue: I’m still not able to insert comments containing non-English characters.
Please, do you or anybody else have other suggestions?

1 Like

This is a collabora issue. It is resolved when you use the most recent version co-2021.

1 Like

Thank you @joergschulz. What would be the nextcloud/collabora version that solves this issue?
Currently I’m using Collabora Online 4.2.3 and Collabora Online - Built-in CODE Server (ARM64) 6.4.1303 and both are the latest (i.e. most up to date) versions of the Stable update channel. Are you referring to another distribution channel?

yes, I half-expected your comment. To be honest: I use a self-compiled version / the master of today:

LOOLWSD version:
21.11.0.1 (git hash: f8f6af5e)
LOKit version: Collabora Office 21.06.6.1 (git hash: 8037a24)

Currently, there is another small issue with comments Line breaks in comments get lost on first edit LOOLWSD version: 21.11.0.1 (git hash: f8f6af5e ) · Issue #3658 · CollaboraOnline/online · GitHub so you might want to test different versions or just wait until the finalized 2021 version will have been released. You can always take the release candidates from docker.io: collabora/code:21rc1 for testing.

Edit: A fix has been inserted to github/master…

@joergschulz, I think I’ll wait until the finalized version will be released and then I’ll update this thread. Thank you very much for the explanation!

1 Like

I have just updated Collabora Online - Built-in CODE Server (ARM64) to version 21.11.4 from the Stable Channel but unfortunately the problem persists.

I have updated Collabora Online - Built-in CODE Server (ARM64) to version 21.11.103 from the Sable Channel but the problem still persists.
Does anybody know in which version will this be fixed?