Talk errors about apache in nginx environment?

Hello,

I’m running Nextcloud in docker compose via nginx. I recently installed the Talk app and went into Administration settings > Talk and noticed this error under Web server setup checks.

Could not detect the PHP and Apache configuration because exec is disabled or apachectl is not working as expected. Please note that PHP can only be used with the MPM_PREFORK module and PHP-FPM can only be used with the MPM_EVENT module.

Any idea why I would be getting an apache related error when I’m running nc on nginx?

Because the Docker container is running Nextcloud in Apache.

Sorry if I was unclear. I have nothing apache in my stack what so ever. Everything, including Nextcloud is running off nginx only. The nextcloud container image I’m using is

image: lscr.io/linuxserver/nextcloud:latest

Okay, I’m not really familiar with that 3rd party image. The official Docker image runs Apache.

same problem.
nginx + php-fpm,

## Web server setup checks

Could not detect the PHP and Apache configuration because exec is disabled or apachectl is not working as expected. Please note that PHP can only be used with the MPM_PREFORK module and PHP-FPM can only be used with the MPM_EVENT module.

Talk
15.0.2

NC 25.0.2

@ViVlVl exact same problem here too…

I have also only noticed this today. I think after the latest update?

yes, in last update developers make change some updates in
“protected function validApachePHPConfiguration()” at [lib/Settings/Admin/AdminSettings.php]

In nginx+php_fpm config this function is not needed.

I just change back value on “if” operator from:

if ($returnCode > 0) {
return ‘unknown’;
}

to:

return true;

Do you happen to have the full path to this file? I’m unable to locate it anywhere in my nextcloud installation directory.

1 Like

your_nextcloud/custom_apps/spreed/lib/Settings/Admin/AdminSettings.php

1 Like

Thank you, this removed the error message.

I was trying to fix this issue but I noticed that return true; is not possible because the function needs a string as return type. In fact what you suggested was causing a talk server error.

Instead using true, I used '' in my code.

I can only recommend not to fiddle with the files in that case. After all, it’s just a warning. There are no functional limitations associated with the warning itself, so suppressing the message does not change anything.

Please wait for the issue to be resolved and until then just ignore the warning: https://github.com/nextcloud/spreed/issues/8436

yes, my mistake :), sorry

1 Like