Talk doesn't work, no ring tone?

talk

#1

Hi all,
I’m no coder, know nothing about Linux. After days of searching and trying to install Nextcloud server on Openshift, I failed , and today I found a tutorial, it’s so easy. I just uploaded “setup-nextcloud.php” into 000webhost, and boom, rest part is so easy.
Then I installed Talk function.
Then I created several users, all in admin group.
Then I tested between two users, with two Android cellphones (nextcloud talk.apk v3.1.1), sending text is ok, but audio call fails ---- caller sees “you started call…you joined the call”, receiver sees "@jack started a call…@jack joined the call ", but receiver gets nothing else, no ring tone or accept/decline icon or anything. Sometimes receiver only sees “@jack started a call”. Anyway, on both ends there’re no ring, no vibration.
That’s nearly my every step! Testing is within one wifi.
What did I miss?
Any help would be appreciated.


#2

If you are both in the room/conversations and you are actively reading the chat messages you will not get the notification.

One person should leave and try then :slight_smile:


#3

Thanks for your help!
Just now I tried, after cellphones reboot, with receiver out of conversation, the call failed to ring on both ends.


#4

Sounds pretty strange. Do you have Google Play Services on your phone, and Notifications app on your server?


#5

Yes, I have them.


#6

Hello, just gave this a go and I did receive notifications on one user’s device, but not on another. I then saw that the one with no notifications had Nextcloud Talk installed from F-Droid so I uninstalled and installed the Google play version. It then received notifications.
I hope this helps, but it’s a shame as F-Droid appears to have lots of obstacles put in its way in its bid to become an alternative to Google pay.
Good luck!


#7

Anything in Nextcloud logs?


#8

Where is the log, please? I can’t find it.


#9

Thanks for your help. I tried to install from another source, still the same.
There’re also some other unordinary things about this app: it never asks me for mic/cam permission; when in a conversation, the built-in back button does not work, I have to use cellphone’s back button. I don’t know if others experience the same problem.


#10

Server log - either apache, nginx or something else.


#11

Sounds super strange, especially since it’s the latest available version :frowning: