Talk and Collabora integration broken after upgrading from 24.0.3->24.0.4

I am running the Hansson’s NextCloud VM (Ubuntu 22.04). After upgrading from NC 24.0.3 to 24.0.4 I am now seeing issues with Talk and Collabora.

The locally hosted Talk high-performance backed responds with 503 errors:


$ curl https://talk.<myexampledomain.com>

503 Service Unavailable

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

----------------------

And the NextCloud office integration fails with bunch of errors in the WOPI/DiscoveryManager.php module on lines# 123-125:


[PHP] Error: Error: Trying to access array offset on value of type null at /var/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php#123 at <>

  1. /var/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php line 123
    OC\Log\ErrorHandler::onError()
  2. /var/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php line 80
    OCA\Richdocuments\WOPI\DiscoveryManager->isProxyStarting()
  3. /var/www/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php line 56
    OCA\Richdocuments\WOPI\DiscoveryManager->fetchFromRemote()
  4. /var/www/nextcloud/apps/richdocuments/lib/WOPI/Parser.php line 41
    OCA\Richdocuments\WOPI\DiscoveryManager->get()
  5. /var/www/nextcloud/apps/richdocuments/lib/TokenManager.php line 226
    OCA\Richdocuments\WOPI\Parser->getUrlSrc()
  6. /var/www/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php line 174
    OCA\Richdocuments\TokenManager->getToken(“*** sensitive parameters replaced ***”)
  7. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 225
    OCA\Richdocuments\Controller\DocumentController->index()
  8. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 133
    OC\AppFramework\Http\Dispatcher->executeController()
  9. /var/www/nextcloud/lib/private/AppFramework/App.php line 172
    OC\AppFramework\Http\Dispatcher->dispatch()
  10. /var/www/nextcloud/lib/private/Route/Router.php line 298
    OC\AppFramework\App::main()
  11. /var/www/nextcloud/lib/base.php line 1023
    OC\Route\Router->match()
  12. /var/www/nextcloud/index.php line 36
    OC::handleRequest()

GET /apps/richdocuments/index?fileId=377&requesttoken=Jh%2BoYKMQSsrM1OUwq0pjnXioqxQdMcHJkPf2X6G8mAI%3D%3AaUvQDct2ZY%2BivIB6mz4n2hXPz18sd478u6%2BXPsWLs08%3D&path=%2FDocuments%2FWelcome%20to%20Nextcloud%20Hub.docx
from XXXXX by YYYYYYY at 2022-08-15T17:19:03-07:00

Any advise on what might be causing this? Everything worked fine before the upgrade.

Thanks!