System uninstalled after update

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version _ 20.0.8_
Operating system and version _Raspberry Pi OS
Apache or nginx version NGinX 1.41
PHP version 7.3

The issue you are facing:

I was running the automatic updater to 20.0.9. It crashed at step 9. When I tried to reload the page just said “update in process”. I checked the manual and tried:

sudo -u www-data php /var/www/nextcloud/updater/updater.phar

but when it asks me ‘should the occ upgrade command be executed?’ it fails:

Nextcloud is not installed - only a limited number of commands are available

And now when I go to log on I get the new install page and the config file has been wiped. I still have backed up files in the /data/updater… directory

What do I need to do to get it working again?
Thanks in advance

Was there written what was done in step 9?

Either the new code is already in place and everything just needs a clean up, or there is something wrong with the new code and it would be better to revert to the previous version…