System reset after write issues

Nextcloud 13.0.4 / Apache / PHP 7.2 / Shared hosting (no ssh!)


I totally lost control of my nextcloud install after a file write issue episode. I may have made the problem worse.


My desktop clients were unable to synchronize, getting the following errors :

Error transferring server replied: Internal Server Error ("Could not write file contents")

Though it may be rights issues, everything seemed fine, but just in case :

  1. I tried to set everything in data/ to 744 or 604.

No success. Then I found out that it was probably a disk space issue : the disk was 100% full and locked by the host. I’m processing a lot of heavy image sequences and heavy documents/videos, all repeatedly overwritten, so I probably should disable or tweak versioning in the future (if I can retake control).

  1. I deleted manually the content of data/user/files_versions/ and data/user/files_trashbin/versions/.

In the meantime I’ve been disconnected, and the web client were returning in the login page an error about issue with the data/.htaccess and impossibility to create htaccesstest.txt.

  1. The data\.htaccess was empty, so I tried to fill it with :
# Generated by Nextcloud on 2017-08-09 17:56:10
# line below if for Apache 2.4
<ifModule mod_authz_core.c>
Require all denied

# line below if for Apache 2.2
<ifModule !mod_authz_core.c>
deny from all
Satisfy All

# section for Apache 2.2 and 2.4
<ifModule mod_autoindex.c>
IndexIgnore *

Current state

Freeing space probably resolved some issues, but the system seems to have been reset and is unavailable.

The web client index page is now showing the installation screen, asking for an admin account and DB settings, as if the system wasn’t installed.

  • I can’t use the previously existing credentials as the admin account already exists.
  • Trying that have overwritten the existing config to a default one, with DB settings (mysql).
  • The file data/.ocdata is empty. I suppose that it shouldn’t, and that it may have been wiped like the neighbor htaccess.

Would you know how to regain access to the system ?