Syncing files (> 75 mb) fails with connection closed - Client versions 2.5.x

I have a local nextcloud server running the latest stable version (15.0.4 as of Feb 17, 2019) on RHEL 7.6. This server does not have end-to-end encryption enabled. Runs on apache.

Everything works perfectly as far as client 2.3.3 goes. However, with 2.5.x, I can no longer sync large files. Nothing has changed on the server side. The EXACT same files can sync just fine with client 2.3.3 but not with 2.5.x.

I only have linux boxes (Fedora 29) and I have tried client packages provided by both Fedora repos and appimage from client download page.

Running the client using

nextcloud --logdir ~/nclogs

I got the following in the logs,

    |[OCC::PUTFileJob::finished |PUT of "" FINISHED WITH STATUS "RemoteHostClosedError Connection closed" QVariant(Invalid) QVariant(Invalid)|
    |[OCC::PropagateItemJob::done |Could not complete propagation of "largefiles/120mb.txt" by OCC::PropagateUploadFileNG(0x55d7a71c9ea0) with status 2 and error: "Connection closed"|
    |[OCC::ActivityWidget::slotItemCompleted |Item  "largefiles/120mb.txt"  retrieved resulted in  "Connection closed"|
    |[OCC::ActivityWidget::slotItemCompleted |Item  "largefiles/120mb.txt"  retrieved resulted in error  "Connection closed"|
    |[OCC::ActivityListModel::addErrorToActivityList |Error successfully added to the notification list:  "Connection closed"|

I have filed this as an issue on the github page -

Any suggestions on how to fix this?

Edit: I have since tried setting up my server with PHP-FPM. No change in behavior. Client version 2.3.3 works, 2.5.x does not work.

Have you some messages on the server side as well? Perhaps a max limit of connections was reached or something similar? The github issue seems to be the right place since it seemed to be working on the 2.3.x client.

Thanks for the reply. I have not seen any messages on the server side. I am still investigating with PHP-FPM though. Hopefully, I can get to the bottom of this.

Have you found a solution to this issue?

I enabled php-fpm and after reinstalling the client, everything started working.

Not sure what the underlying issue is though.