Sync macOS Calender with NC12 in Lan

Hello NC-Community,

I want to sync my calendar between macOS and nextcloud in my local network.

The Nextcloud run on a raspi and is updated to 12.0.3 and the calendar app is already updated to 1.5.5.

First I started with the gernerated URL from NC:
http://192.168.178.32/nextcloud/remote.php/dav/principals/users/admin/
then I modified the URL without an success.

The docs describe here an workaround to redirect the URL from /.well-known/caldav to /nextcloud/remote.php/dav in .htaccess. I’ve created that file and added both lines according to the manual.
But I haven’t an success.

What’s the Problem with mac Software? Do they really use other paths for the calDav / CardDav?
How get I the right URL?

Here some futher Information:

  • My NC is located in /var/www/nextcloud/…
  • There is no DNS available ( the solution use a subdomain instead a subfolder isn’t an option)
  • alternative calendar for mac use although the macOS interface ;(

thx for your help

hello Kalimero

Could you go to your web browser and go in you’re nextcloud instance and login.

Could you tell me what url you get in response ?
If http://192.168.X.X/nextcloud/app/files it’s okay
If http://192.168.X.X/nextcloud/index.php/app/files it’snot okay and you have to setup pretty URL.

Normally you have to go in iCal (calendar now) add a new account in manual mode and type :
Server : http://192.168.X.X/nextcloud (that’s all)
User : admin (in your case)
Password : your password

Hey Nemskiller,

The url http:// 192.168.X.X/nextcloud/app/files doesn’t work. The error message is

Datei nicht gefunden
Das ausgewählte Dokument wurde auf dem Server nicht gefunden.

in english (translated, not original message)

File not found
The following file wouldn’t found on the server.

The url http://192.168.X.X/nextcloud/index.php/app/files works.

I’ve tried the login url http://192.168.X.X/nextcloud, without an success.
I’ve tried admin an 2 user, which use the calendar app

The error message from iCal (now only Calender) is:

Accoutname/Passwort konnte nicht überprüft werden.

translated:

account name /password could not verified.

How could I reinstall prettyURL?
Could it be, that I’ve destroy prettyURL by rewriting .htaccess file.

my .htaccess contains

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

If this file is wrong, could you copy the normal .htaccess file?

thx

You should download again nextcloud and then copy just .htaccess

Open your config/config.php and look if you have this line, if not add it :
‘htaccess.RewriteBase’ => ‘/nextcloud’,

Then save and execute this command

Sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess

If www-data is your web service user
Verifiy if you have this module enabled : rewrite
Then restart your web server

Now index.php shouldn’t appear.

If it is the case retry to set a new account in iCal as i wrote it before