Sync between Client and Nextcloud fails

Hey all,
recently I discovered a Problem in the sync between my nextcloud client on windows 10 and my nextcloud server.
The server is a CentOS 7, running the latest Apache and php7.
The clients are running Win10 and the latest nextcloud client.

I also tested it with the owncloud client, same problem.

When downloading lots of data around 20GB+ at some point the client says, he couldn’t sync a file. As of now, I couldn’t determin if every following file fails, or if it is somthing else.

in the log I get the following error:
{"reqId":"WAmyi9FWhhjyk@m2igl9AgAAAAI","remoteAddr":"134.3.XXX.XXX","app":"PHP","message":"rewinddir(): 120 is not a valid Directory resource at \/var\/www\/html\/nextcloud\/apps\/files_external\/3rdparty\/icewind\/streams\/src\/Wrapper.php#31","level":0,"time":"2016-10-21T06:15:39+00:00","method":"GET","url":"\/remote.php\/webdav\/DSA\/14.%20Karten\/St%C3%A4dte\/Havena%20sw.jpg","user":"Administrator"}

does anybody have any experience with this, or is this some kind of bug?

If you guys need any more data about this, I am happy to provide them.


Can you provide more information, which version of Nextcloud are you running? Do you use external storage? Problem only exists on external storage? Encryption app? New setup or updated, and if updated, did it work before?


the server version is: 10.0.1
no external storage, the /data folder is a symlink to /data/cloud/data as the main partition is pretty limited in space.
I disabled encryption back in owncloud 8 as it performed badly.
it is an updated Setup, first install was I think owncloud 6 and yes it did work before. Don’t know how long that error exists though, I just noticed it this week.

Edit: I just observed that after a while all future downloads exit with the same error

Can you rescan your files, perhaps there is a folder or some files missing/wrongly indexed:
sudo -u www-data php /var/www/html/nextcloud/occ -vvv files:scan username

Not sure about the symlink if that is working or if it can cause problems @icewind , problem is that the change of data-directory is not supported:

thanks for your response, scanning the files worked, will try to rework the partitioning to fix the symlink issue, although I would like to keep the data seperate from the www folder

I understand your problem, together with RealRancor (from the owncloud forum) we constantly remind the developers and with some luck owncloud will provide a solution (which is then hopefully backported):

I really hope that nextcloud will be fixed before owncloud, they are way to slow with the community build, which was why I switched. Maybe I will try some dirty work arounds…

Edit: moved the data directory back into the nextcloud folder… still same issues… maybe I will try and do a fresh install, as I don’t know what the DB has in it after years of upgrading and migration

If there is something not working indicates that there is a real issue. If you still see this problem, it’s perhaps better to open an issue on the bugtracker providing all information in the issue template. Github is more efficient in handling bugs, don’t forget to link the issue here.

yeah I know.
but first I’m gonna copy my OS into a VM and test if it is something broken in the DB or something else.
Don’t want to open an unnecessary issue

last edit: after reinstalling nextcloud and purging the db, everything works fine