Supported Domains for sending welcome mails?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 29.0.5): 29.0.2 - AIO install
Operating system and version (eg, Ubuntu 29.04): Ubuntu 24.04
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 8.3): 8.3

The issue you are facing:
When sending the welcome mail, I have a user account that has a @.consulting email address.
However the mail is never sent. If I send a mail to the user account from my outlook/Thunderburd with the same mail-provider as I’ve configured in NextCloud there are no issues.
Welcome mails to a Gmail address is delivered instant.
I’ve added the IP for my server instance running NextCloud in my SPF record which contains no errors

Is this the first time you’ve seen this error? (Y/N):
Yes

Steps to replicate it:

  1. Add new user
  2. Enter an email address with a non-standard top level domain
  3. Send the email

The output of your Nextcloud log in Admin > Logging:

Nothing in the log since yesterday, so nothing logged

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'one-click-instance' => true,
  'one-click-instance.user-limit' => 100,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'appsallowlist' => false,
  'check_data_directory_permissions' => false,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'nextcloud-aio-redis',
    'password' => 'f0239206af177168a4110e65e6e43bec7851c71a54c5a94c',
    'port' => 6379,
  ),
  'overwritehost' => 'REDACTED',
  'overwriteprotocol' => 'https',
  'passwordsalt' => 'REDACTED',
  'secret' => 'REDACTED',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => 'REDACTED',
  ),
  'datadirectory' => '/mnt/ncdata',
  'dbtype' => 'pgsql',
  'version' => '29.0.2.2',
  'overwrite.cli.url' => 'https://REDACTED',
  'dbname' => 'nextcloud_database',
  'dbhost' => 'nextcloud-aio-database:5432',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_nextcloud',
  'dbpassword' => 'REDACTED',
  'installed' => true,
  'instanceid' => 'ocea9rsjnvq7',
  'maintenance' => false,
  'loglevel' => 3,
  'log_type' => 'file',
  'logfile' => '/var/www/html/data/nextcloud.log',
  'log_rotate_size' => 10485760,
  'log.condition' =>
  array (
    'apps' =>
    array (
      0 => 'admin_audit',
    ),
  ),
  'preview_max_x' => 2048,
  'preview_max_y' => 2048,
  'jpeg_quality' => 60,
  'enabledPreviewProviders' =>
  array (
    1 => 'OC\\Preview\\Image',
    2 => 'OC\\Preview\\MarkDown',
    3 => 'OC\\Preview\\MP3',
    4 => 'OC\\Preview\\TXT',
    5 => 'OC\\Preview\\OpenDocument',
    6 => 'OC\\Preview\\Movie',
    7 => 'OC\\Preview\\Krita',
    0 => 'OC\\Preview\\Imaginary',
  ),
  'enable_previews' => true,
  'upgrade.disable-web' => true,
  'mail_smtpmode' => 'smtp',
  'trashbin_retention_obligation' => 'auto, 30',
  'versions_retention_obligation' => 'auto, 30',
  'activity_expire_days' => 30,
  'simpleSignUpLink.shown' => false,
  'share_folder' => '/Shared',
  'one-click-instance.link' => 'https://nextcloud.com/all-in-one/',
  'upgrade.cli-upgrade-link' => 'https://github.com/nextcloud/all-in-one/discussions/2726',
  'updatedirectory' => '/nc-updater',
  'maintenance_window_start' => 100,
  'allow_local_remote_servers' => true,
  'davstorage.request_timeout' => 3600,
  'htaccess.RewriteBase' => '/',
  'dbpersistent' => false,
  'auth.bruteforce.protection.enabled' => true,
  'ratelimit.protection.enabled' => true,
  'files_external_allow_create_new_local' => false,
  'trusted_proxies' =>
  array (
    0 => '127.0.0.1',
    1 => '::1',
    10 => '172.21.0.1/32',
  ),
  'preview_imaginary_url' => 'http://nextcloud-aio-imaginary:9000',
  'preview_imaginary_key' => '4f53c3230a07b156b8f92cc2a14c036f532abd9601aee86f',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'nextcloud',
  'mail_domain' => 'REDACTED',
  'mail_smtphost' => 'smtp.REDACTED',
  'mail_smtpport' => '587',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'REDACTED',
  'mail_smtppassword' => 'REDACTED',
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'default_phone_region' => 'DK',
);

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

PASTE HERE

You have an option to enable smtp debugging:

I’d check if the mail is accepted from your mail server. If not, you need to find out why, the debug mode hopefully will be verbose enough to show you the details.

If the mails are not accepted and you don’t have enough information, you might want to try:
https://wiki.archlinux.org/title/Msmtp
(also available on other distributions)
it is a local mail server that just transmits mails to another smtp server. It gives you more configuration details and logging.

If the mail was accepted from your mail server, and you have set up the correct From-address, it should send you delivery failure notices with more details (e.g. if the receiving mail server rejected the mail, the server was not available, …)

1 Like

Just clarifying that loglevel has to be adjusted for this as well, as described in the actual documentation: Email — Nextcloud latest Administration Manual latest documentation

I’ll add a note to the config sample now to avoid confusion.

I tried changing my own users mail to this address (I’m in control of this address too).

This is the output from the log:

{"reqId":"9G0cKv84VXTgBoJRmv9K","level":0,"time":"2024-07-01T17:20:12+00:00","remoteAddr":"77.213.101.236","user":"REDACTED","app":"no app in context","method":"POST","url":"/settings/admin/mailtest","message":"Email transport \"Symfony\\Component\\Mailer\\Transport\\Smtp\\SmtpTransport\" starting","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36","version":"29.0.2.2","data":[]}
{"reqId":"9G0cKv84VXTgBoJRmv9K","level":0,"time":"2024-07-01T17:20:13+00:00","remoteAddr":"77.213.101.236","user":"REDACTED","app":"no app in context","method":"POST","url":"/settings/admin/mailtest","message":"Email transport \"Symfony\\Component\\Mailer\\Transport\\Smtp\\SmtpTransport\" started","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36","version":"29.0.2.2","data":[]}
{"reqId":"9G0cKv84VXTgBoJRmv9K","level":0,"time":"2024-07-01T17:20:13+00:00","remoteAddr":"77.213.101.236","user":"REDACTED","app":"core","method":"POST","url":"/settings/admin/mailtest","message":"Sent mail to \"Array\n(\n    [REDACTED@REDACTED] => Asbj\u00f8rn REDACTED\n)\n\" with subject \"Email setting test\"","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36","version":"29.0.2.2","data":{"app":"core"}}
{"reqId":"9G0cKv84VXTgBoJRmv9K","level":0,"time":"2024-07-01T17:20:13+00:00","remoteAddr":"77.213.101.236","user":"REDACTED","app":"no app in context","method":"POST","url":"/settings/admin/mailtest","message":"Email transport \"Symfony\\Component\\Mailer\\Transport\\Smtp\\SmtpTransport\" stopping","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36","version":"29.0.2.2","data":[]}
{"reqId":"9G0cKv84VXTgBoJRmv9K","level":0,"time":"2024-07-01T17:20:13+00:00","remoteAddr":"77.213.101.236","user":"REDACTED","app":"no app in context","method":"POST","url":"/settings/admin/mailtest","message":"Email transport \"Symfony\\Component\\Mailer\\Transport\\Smtp\\SmtpTransport\" stopped","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/126.0.0.0 Safari/537.36","version":"29.0.2.2","data":[]}

And testmail to another domain went fine - so I guess it’s the server at the other end that throws it away… :roll_eyes:

There is a very important technical difference. If the other mail server is just throwing it away, normally it is not supposed to do that, so mails should maximum end up in a spam folder. And if they just throw away mails, it must be with the user’s consent.

Other thing is, if they don’t accept a mail. Still, the user won’t receive it but it is the sending mail server to notify the sender about the problem (or log it). Ideally, they should give a reason so you can fix your server (e.g. if you ip address is on some spam lists, other reasons, might be a config issue on their side as well)…

2 Likes

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.