Suddenly Nextcloud (Docker) stopped Working... help ?!

Nextcloud version : 17.0.2.1
Operating system and version : Ubuntu 18.04
nginx version : 1.17.6
PHP version : 7.3.13

The issue you are facing: Suddenly nextcloud stopped working properly first it startet with me be able to login but no one else the Protokoll showed ( core login faild ) so i started Debugging then i restarted the containers & from there on all gone wrong the domain was not reachable so i debugged more don’t got the problem so i decided to reinstall the docker image im using a docker-compose file from here https://github.com/ichiTechs/Dockerized-SSL-NextCloud-with-MariaDB cleaning up all docker information about docker files and network still not working i wanted to have the server fast up so i reinstalled the server’s os and done it all over again then i got error 500

Is this the first time you’ve seen this error? : Y

Steps to replicate it:

i dont know

sadly i cant provide any nexcloud.log because there is nothing inside checked permission -rw-r–r-- www-data www-data nextcloud.log

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'instanceid' => 'oclar4bxxepe',
  'passwordsalt' => 'HCVA/d0AhA9ct9bZUKBys1ClI/6+sf',
  'secret' => 'vQxBCiYqin/lNIV2TxXkPV63rzJUxaHG7Fxv3GTHKDeJmvyD',
  'trusted_domains' =>
  array (
    0 => 'cloud.cddt.net',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '17.0.2.1',
  'overwrite.cli.url' => 'https://cloud.cddt.net',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'nextcloud',
  'installed' => true,
);

The output of your Apache/nginx/system log in :

Nothing in there

1 Like

I found out that i hit the Let’s Encrypt rate limit i never though i would find my error in the Let’s Encrypt container log’s

There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: cloud.****.net: see https://letsencrypt.org/docs/rate-limits/

is the Let’s Encrypt container by running creating a new crt for my domain every time?

Please enable logging in php. If using php-fpm you will have to point it to your logfile it in your pool config file.

@trendzetter the error is not relatet to the fpm it is the lets encrypt container after trying a spare domain its running again