Stuck While Updating

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04): Unraid 6.8.0, docker 17.0.2-ls55
Apache or nginx version (eg, Apache 2.4.25): distributed with docker
PHP version (eg, 7.1): distributed with docker

The issue you are facing: The documentation for this docker indicates that to perform an update, you first update the container, and then use the Nextcloud GUI to perform the Nextcloud update. When performing the nextcloud update, everything seemed to go fine. However, when I navigate to my nextcloud URL, I get a blank page with the text “Update in process.”

Furthermore, when I navigate to nextcloudurl/updater I get the authentication page asking for the updater.secret from the config file. When I copy the value and paste it in, then click “Login”, it says “Invalid Password”. I changed the updater.secret value, then restarted the docker container, navigated back to nextcloudurl/updater and entered the new password, and it still says “Invalid Password”.

I’m at a loss.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. see above

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'oc4sgozqlq38',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' => 
  array (
    0 => 'redacted',
    1 => 'redacted',
  'trusted_proxies' => 
  array (
    0 => 'redacted',
  'forwarded_for_headers' => 
  array (
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'redacted',
  'overwritehost' => 'redacted',
  'overwriteprotocol' => 'https',
  'dbname' => 'redacted',
  'dbhost' => 'redacted',
  'dbport' => 'redacted',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'noreply',
  'mail_domain' => 'redacted',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'redacted',
  'mail_smtpport' => 'redacted',
  'mail_smtpname' => 'redacted',
  'mail_smtppassword' => 'redacted',
  'maintenance' => true,
  'logtimezone' => 'America/Los_Angeles',
  'log_type' => 'file',
  'logfile' => '/config/log/nextcloud.log',
  'logfilemode' => 416,
  'loglevel' => '2',
  'updater.secret' => 'password123',

The output of your Apache/nginx/system log in /var/log/____:
it seems to be empty

I was able to move past this by updating manually via the command line, per the instructions here:

Still not sure why the GUI didn’t work, but at least I’m back up and running!

I don’t know about the docket image.

The normal nextcloud image has turned off the web gui updater. For good reason.

You do the update by removing the container, remove the image, pull the new image and start it. (docker stop …, docket rm …, docker run …) There is a script executed at startup to check the installed version of nextcloud against the version in the image and perform an update if needed. So there is no need for a gui update.

By this you also get all updates of the underlying container OS. Security patches and so on. :wink: