Stuck in Maintenance Mode after manual upgrade

Nextcloud version : 17.0.2
Operating system and version : Ubuntu 18.04.3 LTS
Apache or nginx version : Apache/2.4.29
PHP version : 7.2

The issue you are facing:

Today I tried to upgrade to 17.0.2 (from 17.0.1) via the integrated updater. I constantly received errors during either Backup or Extracting. So I tried the commandline updater, but noticed, that version.php was somewhat stuck at some 13.x version and totally out of date (at least updater.phar kept showing me these versions). So I thought it wouldn’t hurt if I get a fresh copy and import the config.php, as described in the nextcloud wiki.

Moved the old installation to _old and extracted a new copy of nextcloud 17.0.2 to /var/www/nextcloud. Moved over the config file from _old, adjusted file permissions and ran occ upgrade. (

Nextcloud does show up, but it is still in maintenance mode. And I tried every method I could think of to disable it:

  • occ maintenance:mode --off (also turning it on and off several times)
  • occ config:system:set maintenance --value=false --type=bool
  • occ upgrade (again, returns: Nextcloud is already latest version")
  • php updater.phar (version 16.0.3-3-ga0c2b25 dirty) returns: “Current Version is 17.0.2, No update available.”
  • occ maintenance:repair
  • manually setting maintenance to false in the config.php
  • restarted apache2 several times
  • rebooted the VM several times
  • ran apt update and apt upgrade

Even when reverting back to the _old folder it is still in maintenance mode.

I rebooted my pc, cleared the cache of Firefox, tried to use edge. Always - the same - result.

And lastly, I even copied a backup from the data directory/updater/backups/ back to the web-root, still maintenance mode active. I’m starting to think it’s not coming from the webroot but rather the data directory or database …

Any ideas ?

Is this the first time you’ve seen this error? : Y

Steps to replicate it:

  1. Always present

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



hmmh, you did a lot to get it working again.

Some simple thought:
Are you in the correct folder?
Do you have another nextcloud installation somewhere and your apache config is pointing to it?


thanks for your quick reply. I did not touch the apache configuration and have always been working with the “root” nextcloud folder, /var/www/nextcloud. The only other folders in /var/www/ are nextcloud_old and html. I just moved html and nextcloud_old out of /var/www and guess what …

“The requested URL was not found on this server.” - Wait what? …

Moving back html … and back to maintenance mode. Going into html, finding another nextcloud folder ???

Sometimes the simplest thoughts are the best. Thanks for your hint, I’ve been working in the wrong nextcloud directory for the last 12 hours. Oh lord this is embarrassing … (Can this topic be archived directly ? :woozy_face: )

Thanks rakekniven and Merry Christmas :slight_smile:

Hey, don’t worry.

finally you got it back up again?

Yep. Back on track.

Update via the web-updater failed again “Error parsing download” - Command line updater worked though.

1 Like