Stuck in maintenance mode after failed update - how to reset?

Hi all; tried to online-update a running nextcloud (12.x?) instance on a shared hoster. Failed in “downloading” because apparently our internal firewall somehow blocked the download, with the updater complaining the download failed. Wanted to try the same thing later at home - just to experience after closing the browser tab I can’t even reach the admin page anymore. System says the instance is in maintenance mode.

Is there a way to get rid of maintenance mode again? Browsing the web I found two options to use occ command line tool for that (which I can’t as I don’t have shell access to the machine) or to remove or set to false the “maintenance” parameter in config.php (which doesn’t work).

How to get out of this mess?
Thanks in advance and all the best,
Kristian

Edit config/config.php and set
'maintenance‘ => false,

2 Likes

Yes, already tried that, but that doesn’t do anything. Is there anything else that can be blocking the instance in maintenance?

Ups - sorry. Didn’t read your initial post properly enough.

Not that I know of without shell access.

Just to be sure: are you sure you saved the file after altering it?

What’s the output of https://your.nextcloud/status.php?

No problem. I’ll see whether I can get the status output to work again; meanwhile I tried to restore the instance from the backup the updater (successfully) managed to create - which seems to have completely trashed it. Not nextclouds fault this time, however, but it seems rather a permission issue on my hosters side. :expressionless: More later, I hope…
Thanks so far for your help,
Kristian