Strange problem on new install

I had a test installation of nextcloud that I deleted. I deleted the database, the install directory in /var/www and the data directory.

Today I decided to reinstall the test instance. I used the same URL and passwords. I downloaded the software from

and unpacked it in /var/www/nextcloud. I renamed this directory to /var/www/testcloud.
Inside that directory I ran the installer with
sudo -u www-testcloud php8.1 occ maintenance:install --database "mysql" --database-name "cloud_test" --database-user "nextcloud" --database-pass "mypassword" --admin-user "myadmin" --admin-pass "myadminpassword"
This works so far. However, when I start the instance in the web browser, I get a blank screen. In the log files I get a lot of messages like this:

Failed opening '/var/www/otherinstance/apps/theming/lib//ImageManager.php' for inclusion (include_path='/var/www/testcloud/3rdparty/pear/archive_tar:/var/www/testcloud/3rdparty/pear/console_getopt:/var/www/testcloud/3rdparty/pear/pear-core-minimal/src:/var/www/testcloud/3rdparty/pear/pear_exception:/var/www/testcloud/apps

Why the reference to /var/www/otherinstance ??? That instance exists and works, but has nothing to do with my test instance. I already deleted the browser cache, searched the database and scanned all directories. Nowhere it is referenced. It is excluded by open_basedir.

Any idea?

is this ditectory /var/www/testcloud setup in apache to be hosted?

Yes, the test instance has a virtual host in apache, as has the otherinstance.

What’s more, the test instance worked fine before I deleted it. The problem showed up after reinstallation.

is this correct ?

sudo -u www-testcloud

should it not be

sudo -u www-data ?

you run a custom apache config ? what Operating System?

I changed the ownership of that directory to www-testcloud what is a valid user on my system for security reasons. Also this worked fine before the reinstallation.

The otherinstance also has its own user.

okay cool cool. just checking.

apachectl -t

syntax OK.

mysql test_cloud db dropped before you reinstalled.

i’m out of ideas

So am I. Also restarted apache2 and php8.1-fpm after the reinstallation.