Strange DNS routing

Hi. I set up freedns service using the setup wizard.
I can connect to the server from outside the network. Using the address from freedns, and the public IP of my network.

But when I want to access the same addresses while connected from my home network, the browser shows “page not available”.
Ports 80 and 443 are open. The cloud is visible at the local address

The same thing happens with a phone connected to the local network via wifi.
I can’t connect to the cloud with my phone, but turning on mobile LTE suddenly I get access.

The freedns must inside also resolve to the external ip adress of your router and your router must route the data from inside to inside with the external ip. Search “Hairpinning” and “NAT loopback”. Perhaps you need a new router.
Another possible is to use the nextcloud from inside with the internal ip adress. But this ist mostly a ssl problem. You also can set on pc the hosts-config and switch the freedns name to your internal ip.

You need a DNS server inside your network, which routes the freedns name to the local IP of your cloud server. Using “dnsmasq” can solve this problem.

I tried to change the default ip in dnsmayq setup (from to my local) but it didn’t change anything. The server is still only visible from the outside.
No locally connected device has access. What else do I need to change.
I tried adding ip to the DMZ but that doesn’t help either.

Problem solved. I had to add a DNS entry on my router, not just unblock the ports.
In the DNS menu I added an entry with the address of the website generated by freedns, and the local ip address of the server.