Storing the data in a SSD

Hello. I’m super noob, so sorry if the question is easy, but I don’t find an answer. I set up an SSD of 480gb because I want my data to be stored there. As you can see in the first image, I did set up nc-database and nc-datadir, giving the link of my SSD. However, on the page of system info (second image) it appears that I have only 29 gb of space in the NAS (which corresponds only to the sd card in which I installed next cloud).

Why the 480gb of the SSD don’t show up there? Is my data being stored in the SD card rather than on the SSD? (It appears so because I’ve used 11gb of the SD card and I doubt that NCP only weight that much).


the most easy way I can think of is to log in to your admin account > got to settings > Overview (or something like that) there you should see a nice graphical overview of your drives.

in the terminal you can also do a df -h to see what’s mounted and how much capacity it has.

Did you setup and format the datadir using the setup wizard?

Ok. I checked both the command and the settings>system and I can see now that the SSD is not recognized.

However, when I try to use the setup wizard, the following message appears: “Unauthorized request. Try reloading the page”. I used fix permissions and tried again without success. I also tried to format the SSD again, getting the following error “Please, only plug in the USB drive you want to format” (when I only have one SSD and nothing else in any USB port).

I couldn’t use the setup wizard to set up the SSD for the first time either. Same message: “Unauthorized request. Try reloading the page”. So I did format it manually, fix permissions and change the nc-database and nc-datadir directories to the external SSD. Maybe the problem has that common root…

Ok. I solved it by looking for info about the “Unauthorized request. Try reloading the page” error [Solved] NextcloudPi Panel - Unauthorized request. Try reloading the page.

I just formated the SSD again and used the setup wizard copying and paying the link into another tap. It is an error that has been in NC since 2017 at least.