Storing files and folders on an external USB HDD

Nextcloud version (eg, 12.0.2): 13.0.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04.4 LTS
Apache or nginx version (eg, Apache 2.4.25): 2.4.18
PHP version (eg, 7.1):7.0.28

The issue you are facing:

I recently setup Nextcloud on a Raspberry Pi running the above mentioned server and everything is working as it should. I added an external HDD and is now permanently mounted using fstab to a local directory. I had pasted this mount location during the installation of nextcloud. I then enabled external storage from the settings and added the same path there as well. Now under ‘Files’ on the dashboard, I see a files_external folder and when I check from the terminal, I do see this folder on the hdd. However, this mount path where nextcloud is supposed to store data on the hdd, already has data that I would like to see under ‘Files’. Is there a way to see this without moving all of these files to files_external?

EDIT: Looks like I jumped the gun :slight_smile: The existing files on the HDD folder now do show on the Dashboard. I guess it just needed a minute to refresh. However they don’t seem to be syncing on my local machine using the client. Any thoughts?

My impression is you don’t need the external storage at all. You mounted the external HDD to the Raspberry, so it is already on the local filesystem. Just configure your data directory on that directory.

Did that but all the data that existed in that folder before being pointed at by nextcloud is not syncing. Anyway to make that happen?

So does your datadirectory entry in config.php point to that directory where the HDD is mounted? You seem to expect that files on that drive are synchronized automatically. That is not the case. In fact you have to add them to the cloud via the web. At least that is my understanding.

Ah I see. The HDD is mounted to /cloud/hddext and this is the data directory as well. This folder already has some data that I was hoping to sync automatically.

If it does not sync you can :

  1. Do a force refresh from command line
  2. Check the settings from. Your client (if folders are big a setting prevents auto sync before confirmation)

Or is the issue solved already?