Stop syncing a folder - local folder not completely removed

Nextcloud version : 20.0.8
Operating system and version : debian, yunohost
Nextcloud desktop client : windows 3.2.2

The issue you are facing:
When I stop syncing a folder (uncheck box then apply), the local folder is not completely removed. I think it’s caused by the presence of hidden files, that it doesn’t remove, like “.folder.png", "..DS_Store”, etc… So a big part of the tree view of the folder is kept, with just these hidden files inside.
In Nextcloud desktop parameters, the box “synchronize hidden files” is unchecked.

We really need the local folders to be completely deleted, otherwise it’s just impossible to see clearly what’s synchronized and what’s not, is there a way to do it ? Maybe checking the box “synchronize hidden files” make it work ? But it seems to me that it’s not a good idea to sync hidden files ?

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Synchronize a folder, work on it so that some hidden files are created by the system in this folder
  2. Stop synchronizing it : in nextcloud desktop, uncheck the tick box, then apply.
  3. Check if the local folder is completely deleted
1 Like

Even if I don’t have hidden (dot)-files (e.g. .DS_Store) in the folder, the folder is not removed when unchecking the sync.
I have Win-Client 3.4.1 and Server 21.04.
This problem is also mentioned here Uncheck folders does not delete local files - #2 by svogel

I was not able to reproduce the issue on my system. (Arch Linux, Gnome 41, Desktop Client 3.4.2) If I uncheck a folder it disapears on my computer like it should. There is an issue on Github regarding this. Maybe you could add a comment there…