Stop email notifications

github_issue_filed

#1

Hi all,
I’d like to know how to turn off email notifications upon each file sharing?
People in my company are bored with this emails.


#2

Hi,

As admin you can change the default activity settings for all users:

grafik

In the top there is a checkbox for activity emails in general.
Hope this is what you were asking for.


#3

Thank you!
It was exactly what I’ve been seeking for.
I missed that checkbox at the top of Activity tab.
I unchecked it. Аll other email boxes are also unchecked.
But emails continue coming :frowning:
I’m using the latest 14 release of Nextcloud.


#4

These are the default settings. Each user can still configure their personal notification. Could you check for the affected users in their personal settings as well, if the notification is disabled?
Sorry, should have mentioned that before.


#5

Thank you for your reply, Schmu.
Yes, I checked personal settings as well, but did not find email column.
This column is present in overall admin event settings only (as depicted in your image above). Therefore I’m a bit confused.
I thought that personal settings are intended only for showing events in the so-called “stream”. Did you mean that they are related to email notifications as well? If so, how?


#6

Actually every user has his own activity settings. That’s my user now, unfortunately in German. Nonetheless, you can see the e-mail column and I can define different settings than the one the admins user is providing as default (for new users).
grafik


#7

Well, I figured out that email column disappears if “Send activity emails” checkbox in overall admin settings is unchecked.
I checked it again and found that “A file or folder has been shared” checkbox in Mail column of ordinary user accounts (as well as in personal event settngs for administrator) is unchecked.
Nonetheless, email notifications are not stopped.


#8

I see. This seems to be a bug then.
Could you please open an issue on Github then, please?

Please use the issue template app, which helps you to provide all the necessary and required information to track down the root cause quicker.


#9

OK, I will open another one.
Thank you, Schmu.


#10

would be great if you’d post the issue here and close this thread here in the forum…


#11