Stockage externe vers un serveur de fichier sur le même réseau

Bonjour,
La mise en place d’un stockage externe vers un serveur de fichier situé sur le même réseau échoue avec l’erreur :
Wrong parameters for Exception([string $exception [, long $code [, Exception $previous = NULL]]]) at /var/www/html/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Exception/Exception.php#17

Vers un autre serveur toujours en interne sur le même réseau mais en SFTP, cela fonctionne correctement.
Il s’agit de la version 12.0.4 .
Toutes les options concernant le mode d’authentification et/ou différentes syntaxes pour les partages ou les sous dossiers cibles ne change rien.
L’utilisation de compte utilisateurs ou administrateur ne résout pas le problème non plus.
Ce type d’erreur est-il caractéristique ?

Cordialement

Original Post automatic translated to English:

Hello,
Setting up external storage to a file server on the same network fails with the error:
Wrong parameters for Exception ([string $ exception [, long $ code [, Exception $ previous = NULL]]]) at / var / www / html / nextcloud / apps / files_external / 3rdparty / icewind / smb / src / Exception / Exception .php # 17
To another server still internally on the same network but in SFTP, it works correctly.
This is version 12.0.4.
All options regarding the authentication mode and / or different syntaxes for the target shares or subfolders do not change anything.
Using user or administrator accounts does not solve the problem either.
Is this type of error characteristic?
cordially

My Reply in English

My guess is that there is an issue with SMB3 support. Please check your setup accourding to this post on github:
https://github.com/nextcloud/server/issues/5195
quote: Hi All,Turned out it was caused by security group permission in the root shared folder as I was able to mount the sub-directory. Adding the security group which is used by AD browser to the root shared folder fixed the issue.
Also, the php-smbclient in Ubuntu 16.04 only supports SMB v2. Didn’t work on SMB v3.
sudo apt install smbclient php-smbclient
Edit /etc/samba/smb.conf
[global]
client min protocol = SMB2
client max protocol = SMB3
Hope this help others. :slight_smile:

Ma réponse en français

Je pense qu’il y a un problème avec le support SMB3. S’il vous plaît vérifier votre configuration accourding à ce poste sur github:
https://github.com/nextcloud/server/issues/5195
quote: Salut à tous, Il a été provoqué par l’autorisation du groupe de sécurité dans le dossier partagé racine car j’ai pu monter le sous-répertoire. L’ajout du groupe de sécurité utilisé par le navigateur AD au dossier partagé racine a résolu le problème.
En outre, le php-smbclient dans Ubuntu 16.04 ne supporte que SMB v2. N’a pas fonctionné sur SMB v3.
sudo apt installe smbclient php-smbclient
Editez /etc/samba/smb.conf
[global]
protocole client min = SMB2
protocole client max = SMB3
J’espère que cela aidera les autres. :slight_smile: