SSL with different public ports (8080 and 4443)

Nextcloud version (eg, 12.0.2): 13.0.0
Operating system and version (eg, Ubuntu 17.04): Raspbian Stretch Lite (Kernel: v4.9)
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.25
PHP version (eg, 7.1): 7.0.27

The issue you are facing:
I’d like to access nextcloud from outside my local network through HTTPS. I’ve set up port forwarding in my router so that requests to port 8080 go to the server’s port 80, and requests to port 4443 go to the server’s port 443. Plain HTTP works, but when I try to access, I get the error “Unable to connect”. The error persists even if I change the port forward to 443 --> 443.

which one?

Your reply made me realize what the problem was. I tend to forget I use 2 routers and I forgot to set up the port forward on the second one… Now it works.

Thanks for the hint and especially the quick help! Much appreciated!

1 Like

:smiley: JimmyKater the prophet :smiley:
I would have never guessed that you have two routers. :sweat_smile:


well to be honest i didn’t know myself. :smiley:

i thought more of a router-forwarding problem as i had detected that on one of mine sometimes ago (which is solved in the meanwhile)

but yeah - you can read “which router” as : which of the both routers as well as which model do you run? :wink:

Haha I guessed that you meant the model, but I was like “Wait a second… There’s another one, he’s right!” :smiley:

Again, thank you very much for your help!