SSL Handshake error after client upgrade to 2.6+


I have a self hosted Nextcloud instance that works flawlessly with several clients either at home (Linux) or in mobile (Android). At my work PC (Windows 10, behind HTTPS proxy) desktop client also worked fine until some weeks ago, after upgrading to 2.6, it stopped connecting. Upgrading to 3.0 didn’t solve the issue, and after I fully deleted the account I can’t re-add it, when I specify my server’s URLs it complains about a SSL Handshake error. My linux clients at home work just fine, and if I go back to 2.5 in work’s PC, it works too. Web interface works perfectly.

Any idea what may be happening? I was almost sure it must be related to corporate proxy, because it does some weird things like altering SSL web certificates on the fly, and in browsers I need to load and trust some specific certificates so everything works. But since 2.5 worked fine and now anything beyond 2.6 it doesn’t, I don’t know what to think and it may be something else. Client logs don’t tell anything besides SSH Handshake error, and server logs don’t seem to even realize somebody is trying to connect (so it looks like a 100% client issue).

Thanks in advance!


I have also self hosted nextcloud server in linux machine and nextcloud is running in docker. Yesterday i put proxy to running in docker and create dns address for my cloud. So after this cloud working normally and nice in web browser but when i try to create connection in windows client it says SSL handshake failed and in android client app says: server not found. And i have latest version of windows client.

E: server version is 18

Please try it with another nextcloud account e.g. from . Perhaps it works with or https://demo2.nextcloud.com2 . Nextcloud Demo uses Lets Encrypt certificates. If it works i think you must change your server. If it also not works you must change something at your company.