SSL Error // connection refused on nextcloudpi

ncp

#1
Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

The issue you are facing: Went to log in to my nextcloud via browser and got a connection refused error and on the app on my phone it says there was an ssl error i sshed into the pi and manually updated it and it didnt fix it i also tried connecting directly as i use a dns service but that wasnt the issue either it still refuses when i ssh into it everything appears normal i have no isses so im kind of lost as to what is going on.

Launching nc-info
Gathering information…
NextCloudPi version v0.66.1
NextCloudPi image NextCloudPi_10-23-18
distribution Raspbian GNU/Linux 9 \n \l
automount yes
USB devices none
datadir /var/www/nextcloud/data
data in SD yes
data filesystem ext2/ext3
data disk usage 14G/30G
rootfs usage 14G/30G
swapfile /var/swap
dbdir /var/lib/mysql
Nextcloud check ok
Nextcloud version 14.0.3.0
HTTPD service down
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok
port check 80 closed
port check 443 closed
IP 192.168.1.143
gateway 192.168.1.1
interface eth0
certificates ******
NAT loopback yes
uptime 15min


Launching letsencrypt
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Cert not yet due for renewal
Keeping the existing certificate

This seems like it might be it but idk what to do about this:

[Mon Nov 05 06:25:02.111150 2018] [ssl:warn] [pid 974:tid 1995587984] AH01882: Init: this version of mod_ssl was compiled against a newer library (OpenSSL 1.1.0h 27 Mar 2018, version currently loaded is OpenSSL 1.1.0f 25 May 2017) - may result in undefined or erroneous behavior
[Mon Nov 05 06:25:02.120215 2018] [ssl:warn] [pid 974:tid 1995587984] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name

Is this the first time you’ve seen this error? (Y/N): Yes


#2

Try

sudo systemctl start apache2.service

then check nc-info again


#3

I can fully confirm that problem.

I tried your suggestion sudo systemctl start apache2.service but it doesn’t solve the issue. HTTPD is still down.
Any other suggestions?


#4

Are you trying to access the server via URL https://localhost:4443?
What is the domain name you defined for your server with letsencrypt? Please use that name.


#5

What is output of

sudo systemctl status apache2.service

It should provide clues to why it failed to start


#6

The output is:

pi@nextcloudpi:~ $     sudo systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2; generated; vendor preset: enabled)
   Active: active (exited) since Tue 2018-11-06 08:49:53 UTC; 16min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 10294 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 8509 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SUCCESS)
  Process: 10302 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

Nov 06 08:49:53 nextcloudpi systemd[1]: Starting LSB: Apache2 web server...
Nov 06 08:49:53 nextcloudpi systemd[1]: Started LSB: Apache2 web server.

#7

Its active(exited), should be active (running), so for more clues try output of

sudo tail -40 /var/log/apache2/error.log


#8

Thanks for the fast reply.

Unfortunately the log is completely empty.


#9

Hi @pixelriot are you user @Kin as well? If not, please don’t take over someone else issue.


#10

Then check any of other log files in /var/log/ and /var/log/apache2/
Maybe just got rotated and renamed to error.log.1


#11

Sorry. I will wait then.


#12

@pixelriot you can start your own if you’re issue is not related Kin’s
Make sure you give the issue a telling name. Then explain as detailed as possible what the issue is.


#13

I think my issue is exactly the same, so I would suggest to keep the information together.


#14

For me it doesn’t look the same. For Kin the apache is running and you are stating that the web server is not running:

For Kin the root cause is very likely the usage of a hostname/ domain name which is not included in the SSL certificate and he has to use the correct domain name.


#15

Ok, sorry. I will start a new thread.


#16

please, try this


#17

pi@nextcloudpi:~ $ sudo systemctl status apache2.service
● apache2.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)


#18
sudo apt-get update
sudo apt-get install --reinstall apache2
sudo apt-get install libapache2-mod-authnz-external
sudo apt-get install libapache2-mod-security2