Spreed.ME under NextCloud 10.0.1 stoppping Audio and Video after Connection

I have configured spreed-webrtc-server from source.
I followed this instructions:
a) https://nextcloud.com/webrtc/
b) https://github.com/strukturag/nextcloud-spreedme#installation--setup-of-a-spreed-webrtc-server

The App Spreed.ME (Version 0.3.2) under NextCloud 10.0.1
(PHP 7.0.8, Apache under ubuntu server 16.04.1)
is working -> when i Test the URI https://my-website/apps/spreedme/admin/debug

the result is:
Spreed.ME Version 0.3.2

Ran test #1 (testOwncloudPhpConfigFile):
Passed without an error

Ran test #2 (testOwncloudJavascriptConfigFile):
Passed without an error

Ran test #3 (testSpreedWebRTCAPI):
Passed without an error

Passed all tests. Everything seems to be set up correctly! :slight_smile:

Text-Chat is not the Problem with other users. Spreed.ME is allowed for all registered Users not only for a special group!
Group Feature is disabled!

Now the Problem:
I started a Voice and Video Connection to an invited user

  • my Conn dials … (i can see my own Video)
  • the Screen turns around an split (2 Windows -> …expecting the called Person will appear…)
  • Spreed “dies” immediately and turns back to Text-Chat Mode

What could be the problem, that no Audio nor Video Connection could be established?

I treid also a different way before by using the package in ubuntu … then by editing the /etc/spreed/webrtc.conf instead of /var/www/spreed-webrtc-server/server.conf

Same result …

Thanks for Ideas / Help

You need to setup a stun or turnserver and configure spreed.me to that, if you want to establish video/audio via different networks.

OK, thank you for reply.

So I need to set up e.g. a coturn instance under ubuntu and open the firewall in Router (set it up as exposed host in DMZ)?!

I tried another solution via openVPN Tunnel from one Client to a Client in the Network I called to and it worked fine :slight_smile:

So I have two options .


correct, if your clients, can reach each other directly it works too. Or you use coturn.
But be aware coturn seems to won’t work on a gateway between the clients. As I found out,
all clients need connect trough the same interface, else it can’t handle the connections, somehow.
I got peer timeouts and such stuff.