Spreed.me missing temporary password button

I noticed today that Temporary password button is missing on my spreed.me app when entering a room. I have enabled OWNCLOUD_TEMPORARY_PASSWORD_LOGIN_ENABLED = true; and generated OWNCLOUD_TEMPORARY_PASSWORD_SIGNING_KEY.
However I can’t see this button:

Going to /index.php/apps/spreedme/admin/tp and setting up access for user a results in error but I don’t see anything in the logs.

Any idea?
edit:
I’m using latest stable nextcloud and spreedme app

Hi @muppeth ,

I had the same challenge, and I found the solution somewhere (can’t remember).

You need to create a nextcloud user group “Spreed.ME” and add the respective user to this group. Then the icon should appear.

Give some feedback on it, if it worked.

regards

That does not do the trick. It would we weird if it would. It did work fine on the test machine, and the configs were identical. I will re-deploy it on test tonightand see whats up.

Please post the error code so I can check.
I plan to print out a better error message, not just the error code :slight_smile: Sorry!

Thats the proble. It prints out only:

Error!

I will have a look tonight when comparing to test instance.

For me it also shows an error code:

Error!
50101

I’ve reinstalled spreedme nextcloud app and the error is gone. I have a question though.
Is temporary password option only available to admin users?
I see it on the admin account but not on any non-admin accounts. I saw the config files only mentiones admins but I thought the button makes it possible for everyone to set ‘tp’ on their rooms.

@muppeth hmm… I just tried changing a spreed-enabled user to non-admin, revoked his Spreed.ME group assignement, log him off, restarted the browser and - “key icon” is STILL there and he STILL is able to generate a key.

Strange - maybe there’s some caching involved? I cannot reproduce anything anymore… :expressionless: Switching off admin group or previously functional Spreed.ME group hasn’t got any impact anymore…

Strange things happen to strange people :wink:

I tried on ‘clean’ browser now. Admins have icons while normal users don’t. Spreed.me is enabled for all users on my instance (no group assigned).
I still wonder whether this is how it’s intended to be or is there still some problem with my installation.

If only admins can setup TP my question then is: why? I would prefer everyone using spreedme to decide whether they want to grant access to their rooms to external users (non-nextcloud).

Is temporary password option only available to admin users

The feature is only available to Nextcloud admins and administrators of the Spreed.ME Nextcloud group. See https://github.com/strukturag/nextcloud-spreedme#access-by-non-nextcloud-users

Thanks for making it clear. I understood it from the comments in the config file, but I wasn’t sure it applies to the general link (/index.php/spreedme/admin/tp) or any room created by user.
Why is it like that? If only admins are able to setup TP it makes it very inconvenient for others to request such thing every time they want to have a conference with someone that doesn’t have an account on nextcloud.

If you want to allow all users in your installation to generate Temporary Passwords, simply use:

public function isSpreedMeAdmin() {
	return true;
}

here: https://github.com/strukturag/nextcloud-spreedme/blob/bd2e3f21e23a9b5672fd721113beb1bcaa7729a7/user/user.php#L114-L116

1 Like

Thanks a lot. For now it will do. Would be nice to have as an option in the future so there won’t be need to change the code each time app has an update.

Error!

50103

Using a name that contains:

:-(

Keeping the same keys in WebRTC config files does not help?

@hustenfrei this issue occurs when using one of these disallowed characters in a username:

  • :
  • /