Spreed me initializing anomaly

Hello,

I’m installed spreed me successfully, when i click in the spreed.Me app in nextcloud i get spreed me gui but it can’t detect the user connected (Initializing) in nextcloud.

Initializing turn without stopping and i can’t do nothing in spreed-webrtc (no chat, no video…).
My nextcloud version : 9.0.53
My server : Ubuntu 16.04
My data base : MySql

Thank u

Hi @slim1985,

please take a look at your browser’s developer console and post error messages (if any):

  1. Open the Spreed.ME app in Nextcloud
  2. Append ?debug to the URL, i.e. https://domain.com/index.php/apps/spreedme/?debug
  3. Right click on the Nextcloud site
  4. Click “Inspect element” (very bottom)
  5. Check what it says in the console and paste it her

hi @leon ,
Thank u for ur answers

The console says :
Content Security Policy: La directive « frame-src » est obsolète. Veuillez utiliser la directive « child-src » à la place.(source inconnue)
Using //@ to indicate sourceMappingURL pragmas is deprecated. Use //# insteadjquery.min.js:1
Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à self (« script-src https://localhost ‘unsafe-eval’ »).spreedme
Launching …main.js:304:3
Web fonts loaded.main.js:204:5
Browser support for filesystem API not found.filedata.js:27:3
Enabled mediaDevices adapter …usermedia.js:92:4
Selected language: enapp.js:269:3
Bootstrapping …main.js:291:7
App runtime id: 57i7k0bappdata.js:91:3
Service version: unreleased.1471203534mediastream.js:38:3
"Ws URL: ws://localhost/webrtc/ws"mediastream.js:39:3
Secure Contextual Escaping: truemediastream.js:40:3
Initializing …app.js:164:4
Les propriétés « mozHidden » et « mozVisibilityState » sont obsolètes. Veuillez utiliser les propriétés non préfixées « hidden » et « visibilityState » à la place.visibly.js:83:26
PostMessageAPI: POSTING FROM Location → https://localhost/webrtc/ “TO https://localhost” Object { type: “init” }PostMessageAPI.js:50:3
Screensharing support true screensharing.js:237:4
Initial room path set, continuing to connect …mediastream.js:240:6
Ready to connect …mediastream.js:231:7
Checking for media access …usability.js:78:6
Continue with connect after media check …usability.js:47:7
Initializing complete.app.js:168:5
Connecting …mediastream.js:200:7
Error: The operation is insecure.
Connector.prototype.connect@https://localhost/webrtc/static/ver=1471203534/js/mediastream/connector.js:63:26
mediaStream.connect/<@https://localhost/webrtc/static/ver=1471203534/js/services/mediastream.js:201:7
e/<@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:130:409
uf/this.$get</m.prototype.$eval@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:145:103
uf/this.$get</m.prototype.$digest@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:142:165
uf/this.$get</m.prototype.$apply@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:145:399
f/q<@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:158:322
e@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:45:348
Zf/k.defer/c<@https://localhost/webrtc/static/ver=1471203534/js/libs/angular/angular.min.js:48:275
angular.min.js:117:399

Created new video layout renderer invisible Object { }videolayout.js:367:6
PostMessageAPI: Got event message { target: Window → webrtc, isTrusted: false, data: Object, origin: “https://localhost”, lastEventId: “”, source: Window → spreedme, ports: MessagePortList, eventPhase: 0, bubbles: false, cancelable: false, defaultPrevented: false }PostMessageAPI.js:50:3
PostMessageAPI: Got event message { target: Window → webrtc, isTrusted: false, data: Object, origin: “https://localhost”, lastEventId: “”, source: Window → spreedme, ports: MessagePortList, eventPhase: 0, bubbles: false, cancelable: false, defaultPrevented: false }PostMessageAPI.js:50:3
PostMessageAPI: Got event message { target: Window → webrtc, isTrusted: false, data: Object, origin: “https://localhost”, lastEventId: “”, source: Window → spreedme, ports: MessagePortList, eventPhase: 0, bubbles: false, cancelable: false, defaultPrevented: false }PostMessageAPI.js:50:3
L’utilisation de « getPreventDefault() » est obsolète. Utiliser « defaultPrevented » à la place.jquery.min.js:5:17117

Its hard to read but it actually logged the error. You access your server with https (which is good and required, but Spreed WebRTC does not know about it). Most likely reason is that you missed the configuration step for that. See https://github.com/strukturag/nextcloud-spreedme/blob/master/doc/example-config-apache.md#apache-configuration-sniplet for Apache or https://github.com/strukturag/nextcloud-spreedme/blob/master/doc/example-config-nginx.md#server-context for the guide. The setting you are missing is to set the X-Forwarded-Proto which lets Spreed WebRTC know that the web server is accessed through HTTPS.

thank u @longsleep, @leon
merci

Pb resolved
Pb résolu

Effectivement, la solution est dans RequestHeader set X-Forwarded-Proto ‘https’ env=HTTPS
Cette ligne a été commentée dans le fichier de confiiguration de apache (nextcloud.conf).
Elle a été commentée parceque apache ne demarre pas quand la ligne est active, en fait le problème vient
du fait que la commande suivante n’a pas été saisie : a2enmod proxy proxy_http proxy_wstunnel headers
Je vous remercie pour votre aide.