Specify user of redis.sock in NC

I’m trying to change it to use unixsocket with Redis. But I get an internal error if I use it with NC.

I work fine with the settings below.

 array (
    'host' => '',
    'port' => 6379,
    'password' => 'PASS',

I try to execute “redis-cli -s /var/run/redis/redis.sock” command to try.
Permissions for redis.sock is 755. redis:redis.
I have no problem if I execute the above command as root or redis user, but I can’t execute it if I have login user without permission.
sudo -u root ( or redis) redis-cli -s /var/run/redis/redis.sock

I changed the host item of redis of config.php to “/var/run/redis/redis.sock” with this setting. And when I access NC, an internal error occurs.
I change the user of redis.sock (and parent directory) to a login user. The command of “redis-cli -s /var/run/redis/redis.sock” can be executed as a login user.

Even if I have redis.sock “login user: redis”, I get an internal error when accessing NC. I can’t solve it by changing redis.sock to 777. I tried to add a login user to the redis group, but this does not solve this error.

How can I specify a socket file with NC if I adjust redis.sock?
Please tell me that this may be a basic thing.

Nextcloud 16.0.1, nginx 1.14.2, PHP 7.3.6, redis 5.0.5

I think there is at least an open issue related to the use of a Redis socket.