Specific users can not delete files and the website is unstable

Hi guys
I am facing some serious issues with out Nextcloud server, which has been running fine until lately.
Some users are not able to delete files via the website. When trying to delete a file/folder an error is displayed and the page refreshed itself after 5 seconds. A user with this issue is prompted twice for the password at login and when you try to access content (i.e. show a picture), you need to reenter the credentials again in a password box. Then the content shows.
This happends with the admnistrator account and some users. Not all of them! Some other users claim that everything works as expected! I can see, that the API functions are working fine, because I can still connect users having the website issue to the desktop app in order to create sharelinks.
I have upgraded to the latest version of Nextcloud but without any difference. All consistency checks are OK. All trashcans are empty and locked items deleted (in the DB).
The worst thing is, that when I browse the Nextcloud website from my iPhone, everything works!? I can rename folders, delete files and rename them. This is so strange…

In the nginx logfiles I can see an error:
8160#8160: *13 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] No such file or directory in /var/www/nextcloud/lib/private/DB/Connection.php:64
I have looked in line 64 of the specific file, but can not find anything there.
My Nextcloud logfiles say that:
OC\AppFramework\Middleware\Security\Exceptions\CrossSiteRequestForgeryException: CSRF check failed
But I can not make any sense of this neither…

I run Nextcloud 17.0.2 on Ubuntu 18.04.3 LTS with Nginx 1.14.0 and MariaDB 10.1.43.

Does anyone have any suggestions/ideas how to solve this issue?

I would assume that this is a configuration problem of the used web browser. Sessions are managed using session cookies. If the used browser denies to store cookies or cookies are deleted in any way by a configuration setting or e.g. a privacy addin, the described problem could ocure.

This kind of connection problems could be caused by an incorrect configuration of the database parameters in the Nextcloud configuration file. It might be possible that you’ve configured a socket access, but the socket cannot be accessed by the system user under which the web server is running.

The search function of this forum should allow you to find similar issue reports and the provided solutions.

Hi j-ed

I have tried with multiple browsers on multiple platforms. The only one where it works, is my iPhone! Everywhere else, the site constantly reloads. It also happens on a fresh installed Windows 10 with just Edge :-/ I have spoken to two users, who do not experience the issues. They both use Chrome and everything just works for them!?
The weird thing is, that when i try to login to the server, I get a blank page. When I enter the address bar and begin to type f.x. apps, the browsers history shows the correct path and the page is displayed! When I click the Nextcloud logo after login, I am presented with a white page again. I have been able to reproduce this on different operating systems with different browsers, so this is not an isolated issue. I hope you can follow me, as this is quite confusing!

The socket thing I need to look more into. I am not that firm in these things. Now that I´m having issues, I learn a lot!

Thanks for the input!

As far as I remember white pages can appear if e.g. required php modules haven’t been correctly installed or the server experiences a problem to access e.g. a Redis server. The search function lists several more matches on this:


Hi, I have used the weekend to dig around and I can not fix this. I will setup a new server and migrate the users over.
Case dismissed (hopefully).
Thanks for your kind help!