SPDyn updater not working?

@nachoparker Just had a quick try at this, and the script isn’t in that location?

root@5835564abc08:/usr/local/bin# ls -al
total 192
drwxrwsr-x 1 root staff 4096 Jun 20 06:39 .
drwxrwsr-x 1 root staff 4096 Mar 12 00:00 …
-rwxr-xr-x 1 root staff 3466 Jul 15 06:55 btrfs-snp
-rwxr-xr-x 1 root staff 10133 Jul 15 06:55 btrfs-sync
-rwxr–r-- 1 root staff 514 May 1 20:22 freedns.sh
-rwxr-xr-x 1 root staff 61 Jul 15 06:55 ncc
-rwxr-xr-x 1 root staff 2635 Jun 12 14:00 ncp-backup
-rwxr-xr-x 1 root staff 392 Jul 15 06:55 ncp-check-updates
-rwxr-xr-x 1 root staff 905 Jul 15 06:55 ncp-check-version
-rwxr-xr-x 1 root staff 3034 Jul 15 06:55 ncp-config
-rw-r–r-- 1 root staff 4274 Jul 15 06:55 ncp-diag
-rwxr-xr-x 1 root staff 825 May 17 10:49 ncp-notify-unattended-upgrade
-rwxr-xr-x 1 root staff 860 May 17 10:49 ncp-notify-update
-rw-r–r-- 1 root root 2249 Jul 15 06:55 ncp-provisioning.sh
-rwxr-xr-x 1 root staff 1841 Jul 15 06:55 ncp-report
-rwxr-xr-x 1 root staff 4952 Jul 15 06:55 ncp-restore
-rwxr-xr-x 1 root staff 76 Apr 29 12:00 ncp-scan
-rw-r–r-- 1 root staff 1228 Jul 15 06:55 ncp-suggestions
-rwxr-xr-x 1 root staff 977 Jul 15 06:55 ncp-test-updates
-rwxr-xr-x 1 root staff 1361 Jul 15 06:55 ncp-update
-rwxr-xr-x 1 root staff 5670 Jul 15 06:55 ncp-update-nc
-rwxr-xr-x 1 root staff 640 Apr 29 12:01 ncp-zram
-rw-r–r-- 1 root staff 375 Jul 15 06:55 nextcloud-domain.sh
-rwxr-xr-x 1 root staff 70856 Apr 29 12:01 noip2

I can only find a script by the correct name in /data/ncp , but that’s the one I tried to change before which didn’t work (my changed script is still there).

I think that you have to activate the script for it to appear

It is enabled (and working fine using curl).

On my NCP panel I see both the spDYN and spDYN-curl (the second being my backup copy to revert to) which is what is in my /data/ncp directory.

I don’t understand your question. It is in /data/ncp, right? what else do you need?

OK I’ll try to explain.

Initially I found the file in /data/ncp (I have the /data folder as a volume linked outside the container) and make my backup duplicate then edited the original to swap curl to wget (plus the other tweaks listed above). It appeared to work, but as a check I also changed the messages (the ones in German) so I could confirm that my changes were being seen (ie that I was editing the right file).

When I made the changes and went to the NCP dashboard, I see both my backup and the original script, but if I run the modified one it works but the messages are unchanged, so I wasn’t sure I was actually running the version that I’d modified (ie it may be working only due to it still using curl, via running the wrong script or having it cached somewhere).

Hence I asked above, and you pointed me to /usr/local/bin within the container itself, but as noted I don’t see the script at all there (just what I listed above).

So I’m now wondering exactly what file (and where) I should be editing to make the curl–>wget adjustment in the right place to properly test it and give a meaningful and hopefully useful (and working) change.

ok, I am looking at the code. Whenever you use spDYN (original or modified one) the file /usr/local/etc/spdnsupdater/spdnsUpdater.sh gets created/overwritten. I guess I confused you in my previous post, sorry.

That is not the ideal location. It should be at /usr/local/bin but the person that contributed this script placed it in /usr/local/etc. Not a big deal, but it would be better if it was in /usr/local/bin/

So you can check the contents of that file after running your modified version from ncp-web to see if your changes appear there. There should be no references to curl for example.

Hope it helps, thanks!

OK that’s a bit clearer. Thanks.

I’m on another business trip until the end of next week, but will have a look once I’m home again.