SpDYN Update does not work

Hi together,

I had to setup a new image after a blackout, because the file system seemed to be currupted. After restoring my backup I’m failing to enable spDYN. I have tried it in the Web panel and in the terminal with ncp-config.
I have checked /etc/cron.d/spdnsupdater
10 * * * * root /usr/local/etc/spdnsupdater/spdnsUpdater.sh *******.*****.de xxxx-yyyy-zzzz >/dev/null 2>&1 (placeholders added)

Host update does not work. When I check in the dashboard of spdyn I can read only: The token for this host was created on 26.03.2021 at 21:52:31 o’clock but never used.

When I try to do in the terminal I get as response two brackets only :frowning:

pi@nextcloudpi:~ $ sudo /usr/local/etc/spdnsupdater/spdnsUpdater.sh *******.*****.de xxxx-yyyy-zzzz
pi@nextcloudpi:~ $

I have tried it with the update token and with the move token. No change …

Does somebody has an idea? Thanks in advance!

I use a Rapberry Pi 2B.
NextCloudPi version v1.35.0
NextCloudPi image NextCloudPi_09-05-20
distribution Raspbian GNU/Linux 10 \n \l
automount yes
USB devices sda sdb
datadir /media/Cloud_NAS44/data
data in SD no
data filesystem btrfs
data disk usage 8.0G/58G
rootfs usage 2.2G/7.1G
swapfile /media/Backup/swap
dbdir /var/lib/mysql
Nextcloud check ok
Nextcloud version
HTTPD service up
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok
port check 80 open
port check 443 open
interface eth0
NAT loopback no
uptime 11:32

Ran a scrub?
When in doubt, I check dmesg and syslog.

Hi OliverV,

I did not spend to much time to repair the old installation. The former installation was running ~ 2 years on Raspian, so I have used the “chance” to update to buster. I have used a new SD card with a fresh image and restored my backup. The backup of settings was very old so I have done everything new.

I remember in past the DNS update at spDYN was done with user/PW/hostname. That was working for me. Middle of 2020 they have changed to hostname/token. That is not working for me :frowning:

But is seems the old way is not implemented anymore…

### Usage
#       Recommended usage:      ./spdnsUpdater.sh <hostname> <token>
#       Alternative usage:      ./spdnsUpdater.sh <hostname> <user> <passwd> (not implemented)


Solution which works for me:
replaced with the file from here: