Sometimes unauthorised WOPI-Host

Hey guys,

Sometimes I have a problem with collabora. It works like it should, but in some cases (e.g. reboot, install an update for docker) I have to stop the container and restart it.

The command to start collabora is:

sudo docker run -t -d -p -e 'domain=example\\.my-domain\\.com' --restart always --cap-add MKNOD collabora/code

Nextcloud and collabora using the same domain and port 443

It would be nice if anyone have an idea :smiley:


I have the exact same issue. I am getting the Unauthorized WOPI Host every time I create the document and open the document it starts to load the Collabora online interface and then it shows this pop up.

I did find this information, none of which has worked for me yet

Any assistance would be great, I’m sure we are not the only folk with this issues having followed the setup steps.

Thanks in advance.

Thank you for your response. I checked the docker container again and I found an interesting detail.

The steps:

  1. Reboot Debian

  2. After complete boot check docker with sudo docker ps

     CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                    NAMES
     4e568ab2a208        collabora/code      "/bin/sh -c 'bash st…"   5 months ago        Up About a minute>9980/tcp   nostalgic_varahamihira
  3. Stop the docker container with sudo docker stop ContainerID

  4. Restart container with sudo docker run -t -d -p -e 'domain=sub\\.my-domain\\.com' --restart always --cap-add MKNOD collabora/code

  5. Check docker again:

     CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                    NAMES
     0dcac848b170        collabora/code      "/bin/sh -c 'bash st…"   4 seconds ago       Up 2 seconds>9980/tcp elated_lamport

They are using different IP addresses. The first container (who started after each boot) using and the new one the correct local IP address :thinking:

Does anyone know a way to modify the first one?

EDIT: I dont know why, but the first IP Address (after reboot) is now and I still get the same error message…:thinking::thinking::thinking: