Some huge problems after fixing broken update

Hello everyone

Tonight I wanted to update NC to 23.0.0 in my docker setup. So, I changed my docker compose to get the newest version.

On my Test-System I was on 22.2.3 and everything worked as it should.
However, I didn’t notice that my prod system still was on 22.1.1. So, the update failed because of major update only works if the system is on the newest previous major version.

So, I changed my docker setup back to 22.1.1 and had to mount only the config and data folder, because otherwise the container crashed after start.

With that, I was able to update our prod system to 22.2.3 and then to 23.0.0.

After the upgrade to NC 23 it showed me, that almost all of my apps (like talk) aren’t compatible anymore in the current version. But no updates for them were shown. So I installed them for now manually by moving the newest app files to the app folder. But here already must be the problem, because NC wasn’t able anymore to find any App Updates.

I tried to update the Apps by OCC, but that didn’t work, because I have to be the www-data user.
So I tried to run the command with sudo -u www-data, but sudo isn’t available in the package.
So I tried to get sudo with apt-get, but the apt-get update command can’t build a connection to the server.

So, somehow, the container does have some issues with connections like the app channel or the debian package channel in general. However, Nextcloud itself is reachable from outside.

I have no idea right now, where the issue could be, and I also have no idea to find the issue, if I can’t install basic tools like sudo or ping in to the connector.

I would be really helpful if someone could help me to fix our setup.

My Docker-Compose Setup:

version: '2'


    image: mariadb:10.5.11
    container_name: nextclouddb
    restart: always
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
      - /share/CACHEDEV1_DATA/Dockerconfig/Nextcloud-DB:/var/lib/mysql
      - MYSQL_PASSWORD=xxx
      - MYSQL_DATABASE=xxx
      - MYSQL_USER=xxx

    image: nextcloud:23.0.0-apache
    container_name: nextcloudapp23
    restart: always
      - 8321:80
      - db
      - /share/CACHEDEV1_DATA/NextCloud:/var/www/html
      - MYSQL_PASSWORD=xxx
      - MYSQL_DATABASE=xxx
      - MYSQL_USER=xxx
      - MYSQL_HOST=db

    image: jlesage/nginx-proxy-manager:latest
    container_name: proxy1
    restart: always
      - 35443:4443
      - 35080:8080
      - 35081:8181
      - LANG=de_DE.UTF-8
      - TZ=Europe/Berlin
      - /share/CACHEDEV1_DATA/Dockerconfig/nginx:/config

My config File:

$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
    1 => 'xxx',
    2 => 'xxx',
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'version' => '',
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'xxx',
  'mail_smtpport' => '465',
  'mail_from_address' => 'info',
  'mail_domain' => 'xxx',
  'mail_smtpname' => 'xxx',
  'mail_smtppassword' => 'xxx',
  'overwriteprotocol' => 'https',
  'force_language' => 'de',
  'force_locale' => 'de_CH',
  'skeletondirectory' => '/var/www/html/data/Robin/files/Anleitungen/NextCloud',
  'maintenance' => false,
  'loglevel' => 2,
  'app_install_overwrite' => 
  array (
    0 => 'announcementcenter',
    1 => 'quicknotes',
    2 => 'spreed',
    3 => 'group_everyone',
  'theme' => '',

After hours of searching the issue, I only had to restart the machine to get it working.
Something was corrupted with docker itself.