(solved ?) Windows desktop client unable to sync. Android works fine Version 12 Beta 4

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):


Nextcloud version 12.0 beta 4:
Operating system and version Ubuntu 16.04:
Apache or nginx version _ Apache 2.4.18:
PHP version PHP 7.0.15:
Is this the first time you’ve seen this error?: Has never worked properly since installing the client with this server

Can you reliably replicate it? (If so, please outline steps): yes. Open the client and Force Sync.

The issue you are facing:
The desktop client will not sync properly. Android app works fine. Gives errors like “operation Canceled” and “info - server replied: Service Unavailable”

Occasionally it will sync properly. I can access all the files through android or web interface.

The output of your Nextcloud log in Admin > Logging:

Sabre\DAV\Exception\ServiceUnavailable: HTTP/1.1 503 Could not open file

/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 85: OCA\DAV\Connector\Sabre\File->get()
[internal function] Sabre\DAV\CorePlugin->httpGet(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method GET’, Array)
/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/nextcloud/apps/dav/lib/Server.php - line 245: Sabre\DAV\Server->exec()
/var/www/nextcloud/apps/dav/appinfo/v2/remote.php - line 33: OCA\DAV\Server->exec()
/var/www/nextcloud/remote.php - line 162: require_once(’/var/www/nextcl…’)
{main}

PHP fopen(/mnt/md0/3tb_share/next_cloud/prcdslnc13/files/NextCLoud config info.txt): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Files/Storage/Local.php#277 2017-05-18T17:00:26-0500
Error PHP fopen(/mnt/md0/3tb_share/next_cloud/prcdslnc13/files/Nextcloud.mp4): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Files/Storage/Local.php#277 2017-05-18T17:00:26-0500
Error PHP fopen(/mnt/md0/3tb_share/next_cloud/prcdslnc13/files/Nextcloud Manual.pdf): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Files/Storage/Local.php#277 2017-05-18T17:00:26-0500

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'instanceid' => 'oczbfmkwajkt', 'passwordsalt' => , 'secret' => , 'trusted_domains' => array ( 0 => ', ), 'datadirectory' => '/mnt/md0/3tb_share/next_cloud', 'overwrite.cli.url' => ', 'dbtype' => 'mysql', 'version' => '12.0.0.21', 'dbname' => '', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => '', 'dbpassword' => ', 'logtimezone' => 'UTC', 'installed' => true, 'maintenance' => false, 'loglevel' => 2, 'updater.release.channel' => 'beta', 'theme' => '', 'updater.secret' =>, ); The output of your Apache/nginx/system log in `/var/log/____`: --- Remember, this information may be requested if it isn't supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

From what I can tell i had files that were corrupt in the directories. When I tried to access the files from the web interface I got errors as well. Deleted those, uploaded new files to test, things seem to be working now.