[Solved] Windows 7 Client crashes on startup Windows 7 64 on Virtualbox

Hey all,

As it says on top, running the latest client on Windows 7 64 bit inside VirtualBox (Version 5.2.32_Ubuntu r132056). Host is Kubuntu 18.04.3 LTS.

Tried starting it from the command line DOS with logging enabled and got this:

[OCC::Application::setupLogging “################## Nextcloud locale:[en_AU] ui_lang:[] version:[2.5.3daily-Win64 (build 20190725)] os:[Windows 7 SP 1 (6.1)]”
[OCC::Application::setupTranslations Using “en_US” translation
[OCC::SocketApi::SocketApi server started, listening at “\\.\pipe\ownCloud-Johan”
[OCC::FolderMan::FolderMan setting remote poll timer interval to 5000 msec
[OCC::AccountManager::restoreFromLegacySettings Migrate: restoreFromLegacySettings, checking settings group “Nextcloud”
[OCC::AccountManager::restoreFromLegacySettings Migrate: checking old config “C:/Users/Johan/AppData/Roaming/ownCloud/owncloud.cfg”
[OCC::ownCloudGui::setupContextMenu Tray menu workarounds: noabouttoshow: false fakedoubleclick: false showhide: false manualvisibility: false
[OCC::FolderMan::setupFoldersMigration Setup folders from “C:/Users/Johan/AppData/Roaming/Nextcloud/folders” (migration)
[OCC::ClientProxy::setupQtProxyFromConfig Set proxy configuration to use the prefered system proxy for http tcp connections
[OCC::ownCloudGui::slotOpenSettingsDialog No configured folders yet, starting setup wizard
[OCC::WebViewPage::WebViewPage Time for a webview!
[unknown Please register the custom scheme ‘nc’ via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
[OCC::SocketApi::slotNewConnection New connection QLocalSocket(0x5c46ec0)

The Kubuntu host client installed and works perfectly. No issues.

Anybody with a similar experience or some advice?

Thanks!

I had the same issue, I think. VirtualBox on Linux Mint, running Windows 7 x64. Installed Nextcloud client and it crashed on first start. I managed to work around is this way:

  • msconfig
    then in the startup tab checked start Windows in safe mode, also checked network.
  • started Windows in safe mode
  • setup nextcloud account
  • msconfig
  • disabled safe mode in the startup tab, restart and now it does work

Thanks that solved the issue, even after uploading the latest Windows version.
Interesting to note that on this configuration, Google Drive sync consumed around 30% CPU, where the Nextcloud sync only uses around 7% during initial update. Win win :slight_smile: