[Solved] Why isn't half the interface loading?

So, around half my Nextcloud UI isn’t loading after a fresh install. It’s on Alpine Linux (in an LXD container behind an Nginx reverse proxy) using Nginx, php-fpm, and mariadb. I’m reasonably sure that it’s some kind of permissions issue, but I have no idea what.

PHP-FPM is set to the right user, as is Nginx. I set up the basedir thing, and added the temp directory. I did everything I can think of.

Frustratingly, it worked perfectly on my local test server. On this VPS… ah well. I’ve tried both the web installer and the zip file. Same problem.

Here’s a screenshot:


Open console and Network debugging, you will see that probably css, js or something else could not be downloaded. When you see what is missing, you can start debug it, e.g. It could be CSP settings in your Provider that forbid js download.

For some reason, it was the actual nginx config file. The one from Nexcloud’s website had some sort of incompatibility with my system. I more or less cut out the bits that I thought didn’t make sense until it worked.