(SOLVED) Upload not possible / no error log


since a few days I’m not able to upload files. Either with the android app nor per browser. But I don’t receive a error message. It shows only “connection lost”.

The log in Nextcloud shows several errors:

chmod(): Operation not permitted at /media/729d29be-0baa-4fe6-9f58-33d102f2f264/nextcloud/lib/private/Config.php#243

rename(/var/log/nextcloud.log,/var/log/nextcloud.log.1): Permission denied at /media/729d29be-0baa-4fe6-9f58-33d102f2f264/nextcloud/lib/private/Log/Rotate.php#49`

But I don’t believe that these are related to my upload issue.

I checked the permissions. And the www-data has the rights to write and read.

Any thoughts or ideas. How do I get a detailed error message?

is your disk full?

No, not at all. Plenty of free space.

please install app issue template and post it’s output here… so that the forum can get an impression aboiut your settings and environment.

I can not install any app over the webinterface. It shows “install” but nothing happens. It seems that I can only view everything but not change any settings. Maybe there is an issue with the nginx server. But how can I figure this out?

Edit: My nginx server error log says “access forbidden by rule”

Any ideas?


pls try to fill this out as good/detailed as possible…

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):

Nextcloud version (eg, 10.0.2):
Operating system and version (eg, Ubuntu 16.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 5.6):
Is this the first time you’ve seen this error?:

Can you reliably replicate it? (If so, please outline steps):

The issue you are facing:

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

Issue not occuring anymore. It seems to be an issue with connecting from another country with VPN over cellular network. I was in vacation one week and now I’m back in Germany and everything works fine. Even over cellular network. Strange.

wow. this is really strange. where have you been?
maybe the cell-provider there it closing needed ports? strange, you’re right

  • and everything is working great now… it’s the right time to install said app :wink:

Yes strange. I was in the Netherlands. I will try to research more.

And I installed the issue template APP like you suggested.

1 Like

I would guess that there is some security feature to block some “evil” IP addresses…

right, maybe it got blacklisted as well.
but nextcloud.log should know this.
plus: usually the ip of a mobile connection doesnt stay the same for very long. it should have been possible to log-in/change things from time to time, at least

nextcloud.log shows nothing related to this. I guess that the issue was alread connecting to the server through my VPN (FritzBox). Because if I was able to reach the server (for example view files with the android APP) the logs are fine. But for all actions where I had issues (uploading) no entry in the logs at this time is available. Unfortunately I can not check now anymore.

maybe so… since especially avm-vpn on win 10 seems to be still in beta.
anyways. so it’s solved and this is what counts in the end. plus maybe: it wasn’t a nc-problem, most probably :wink:

I’m having the same issue , I report it here but no body helped me so far. I would appreciate any help as i’m stuck with this issue for days.