[Solved] Upgrade to 16.0.1 WEB is fine until

I’ve been using NextCloud without problem for years now!

I’ve done the upgrade from 15 to 16 last week

Installation went well, everything seamed to be good but…

WEB interface is fine, I can walk through the directories, open images, but I get errors as soon as I try to open and visualise PDF or ODT files.

  • Internal server error
    -Error PHP Module ‘pgsql’ already loaded at Unknown#0
    -Fatal webdav Doctrine\DBAL\Exception\SyntaxErrorException: An exception occurred while executing 'INSERT INTO "oc_file_locks
    -[Wed May 22 08:34:30.498550 2019] [authz_core:error] [pid 28402] [client xx.xx.xx.xxx:XXXXX] AH01630: client denied by server configuration: /var/www/nextcloud/config

Other problem
Desktop Sync does not work any more

  • connexion closed

APP Sync does not work either

I’ve already reviewed my apache2 configuration
Everything seamed fine

Need help or advise.
Thanks
Jean

Hi,
which postgresql version are you running? Check https://docs.nextcloud.com/server/16/admin_manual/installation/system_requirements.html

Had this error, I was using postgre version 9.3

Hi Andres,
You are my saver…
I havent seen the psql prerequisit…
Like you I was on 9.3 after upgrading to 9.5 my nextcloud runs again (after one month)…
Many thanks
Jean

You are welcome!

Good to know it worked for you, will upgrade postgresql version today.

Regards

Worked for mee too.

Could you please mark this as solved?

Regards