[SOLVED] Upgrade from 12.0.6 to 13.0.1 - not offered

Nextcloud version (eg, 12.0.2): 12.0.6
Operating system and version (eg, Ubuntu 17.04): Ubuntu artful
Apache or nginx version (eg, Apache 2.4.25): 1.21.1
PHP version (eg, 7.1): 7.1.11

Owncloud initially installed manually, no snap, no docker !

The issue you are facing: I’ve updated from 12.0.4 to 12.0.6, but now no further version is shown for upgrade - especially the new 13.0.1 is not listed

I’ve switched the upgrade channel to beta (found the hint on the forums indicating the newer version would only be progressively made available to the user base) and re-ran the cronjob but also there the message “Your version is up to date”

config.php indicates ‘updater.release.channel’ => ‘beta’,

then tried console-based updaters :

sudo -u www-data php updater/updater.phar
Nextcloud Updater - version: v12.0.4RC1
Current version is 12.0.6.
No update available.
Nothing to do.

sudo -u www-data php occ upgrade
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see http://php.net/manual/en/book.pcntl.php
Nextcloud is already latest version

so how can I get the 13.0.1 version onto my system besides downloading the tarball, manually extracting it etc… ?

many thanks

Forgot to mention that the caniupdate app reports green : Can I update? Yes! All apps have a version for Nextcloud 13 available

Updater log :
tries to read from https://updates.nextcloud.org/updater_server/?version=12x0x6x1xxxstablexx2018-03-13T19%3A04%3A15%2B00%3A00+b5e7676355120ec18be8833d8cf451114aa9b17fx7x1x11
returns no content

Solved by setting version to in config.php and running the console-updater. Reverted change in config.php immediately once it proposes the update to 13.0.1

@jhf2442 That is misleading info, you cannot do that.
Nextcloud will immediately report wrong version.

@giorgio09 well… worked for me !

I only changed the version to trick the updater into getting the link to the ZIP of the 13.0.1 release. I’ve looked at the way the updater checks for a new version, and somehow when reporting 12.0.6 it will not be notified of a new 13.x release. When pretending to be 13.0.0, the update to 13.0.1 will be offered.

As soon as the updater asks if it should proceed with the update (y/N), I revert the change in the config and only then press ‘y’, thus having the further update process acting correctly for the update 12.0.6 -> 13.0.1

Not sure if this works in the browser, but in the console it worked.

Thanks, this workaround helped me updating my Nextcloud-installation!

I didn’t get any update offer from 12.0.6 too, even if I switch to beta.

Some problem here. I upgraded from 12.0.5 to 12.0.6 via the web upgrader last week. When I had 12.0.5, 13.0.0 was always available as upgrade. Since the upgrade to 12.0.6 no upgrade to any 13.0.x is available.

Same here:

  • I am on a managed NC at speibox.de
  • Got update from 12.0.5 to 12.0.6
  • No update to any 13 available over GUI

Ah: Activated app “Can I update?” and found the issue(s):

Deactivated both apps, but still no NC 13 available:


Only daily is available:


ummm… could you please report this behaviour as a bug in github?

Yes, I will.
Perhaps something to do with the updater.secret?

Here is my config.php:
$CONFIG = array (
‘instanceid’ => ‘xxxxxxxxxxxx’,
‘passwordsalt’ => ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxx’,
‘secret’ => ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx’,
‘trusted_domains’ =>
array (
0 => ‘xxxxxxxxxx.speibox.de’,
‘datadirectory’ => ‘/var/kunden/xxxxxxxxx/files’,
‘overwrite.cli.url’ => ‘https://xxxxxxxx.speibox.de’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘xxxxxxxxx’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘xxxxxxxxxxxxx-clouder’,
‘dbpassword’ => ‘xxxxxxxxxxxxxxxxxxxxxxxxxx’,
‘installed’ => true,
‘default_language’ => ‘de’,
‘defaultapp’ => ‘files’,
‘knowledgebaseenabled’ => true,
‘enable_avatars’ => true,
‘allow_user_to_change_display_name’ => true,
‘token_auth_enforced’ => false,
‘auth.bruteforce.protection.enabled’ => true,
‘maintenance’ => false,
‘mail_from_address’ => ‘mail’,
‘mail_smtpmode’ => ‘php’,
‘mail_domain’ => ‘xxxxxxxxx.speibox.de’,
‘check_for_working_webdav’ => true,
‘check_for_working_wellknown_setup’ => true,
‘check_for_working_htaccess’ => true,
‘config_is_read_only’ => false,
‘trashbin_retention_obligation’ => ‘auto’,
‘theme’ => ‘’,
‘loglevel’ => 2,
‘enable_previews’ => true,
‘preview_max_x’ => 2048,
‘preview_max_y’ => 2048,
‘preview_max_scale_factor’ => 10,
‘preview_max_filesize_image’ => 50,
‘preview_libreoffice_path’ => ‘/usr/bin/libreoffice’,
‘preview_office_cl_parameters’ => ’ —headless —nologo —nofirststartwizard —invisible —norestore —convert-to pdf —outdir ',
‘enabledPreviewProviders’ =>
array (
0 => ‘OC\Preview\PNG’,
1 => ‘OC\Preview\JPEG’,
2 => ‘OC\Preview\GIF’,
3 => ‘OC\Preview\BMP’,
4 => ‘OC\Preview\XBitmap’,
5 => ‘OC\Preview\MP3’,
6 => ‘OC\Preview\TXT’,
7 => ‘OC\Preview\MarkDown’,
8 => ‘OC\Preview\Illustrator’,
9 => ‘OC\Preview\Movie’,
10 => ‘OC\Preview\MSOffice2003’,
11 => ‘OC\Preview\MSOffice2007’,
12 => ‘OC\Preview\MSOfficeDoc’,
13 => ‘OC\Preview\OpenDocument’,
14 => ‘OC\Preview\PDF’,
15 => ‘OC\Preview\Photoshop’,
16 => ‘OC\Preview\Postscript’,
17 => ‘OC\Preview\StarOffice’,
18 => ‘OC\Preview\SVG’,
19 => ‘OC\Preview\TIFF’,
20 => ‘OC\Preview\Font’,
‘comments.managerFactory’ => ‘\OC\Comments\ManagerFactory’,
‘systemtags.managerFactory’ => ‘\OC\SystemTag\ManagerFactory’,
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘localhost’,
‘port’ => 6379,
‘timeout’ => 0,
‘password’ => ‘’,
‘dbindex’ => 0,
‘memcached_servers’ =>
array (
0 =>
array (
0 => ‘localhost’,
1 => 11211,
‘cache_path’ => ‘’,
‘cache_chunk_gc_ttl’ => 86400,
‘sharing.managerFactory’ => ‘\OC\Share20\ProviderFactory’,
‘tempdirectory’ => ‘/var/kunden/xxxxxxx/tmp’,
‘hashingCost’ => 10,
‘blacklisted_files’ =>
array (
0 => ‘.htaccess’,
‘share_folder’ => ‘/’,
‘filesystem_check_changes’ => 0,
‘part_file_in_storage’ => true,
‘mount_file’ => ‘/var/kunden/xxxxxxxxxx/httpdocs/nextcloud/data/mount.json’,
‘forwarded_for_headers’ =>
array (
‘max_filesize_animated_gifs_public_sharing’ => 10,
‘filelocking.enabled’ => true,
‘filelocking.ttl’ => 3600,
‘cipher’ => ‘AES-256-CFB’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘debug’ => true,
‘updater.release.channel’ => ‘beta’,
‘updater.secret’ => ‘$2y$10$zHP.rZ/taep7UacJFM.RYO8OeQlHYhYaRjctL4/vjpqV7cymyL1aq’,

I have the very same problem, tried this morning again with the same results: changed channels, used cli, nothing excepts daily updates are offered. Didn’t mess with the config though - seems wrong for a production instance…

|Operating system|CentOS Linux 7.4.1708|
|Perl version|5.016003|
|Path to Perl|/usr/bin/perl|
|BIND version|9.9|
|Postfix version|2.10.1|
|Mail injection command|/usr/lib/sendmail -t|
|Apache version|2.4.6|
|PHP versions|5.4.16, 5.5.38, 5.6.25, 7.0.10, 7.1.15| using 7.1.15
|Webalizer version|2.23-08|
|Logrotate version|3.8.6|
|MySQL version|5.5.56-MariaDB|
|ProFTPD version|1.35|
|SpamAssassin version|3.4.0|
|ClamAV version|0.99.4|

I asked the Admin of speibox.de and got the following answer:


darauf habe ich direkt keinen Einfluss. Hast du probiert zwischen beta und stable einmal hin und her zu wechseln? Also einmal beta einstellen, dann Seite neuladen, dann stable einstellen und Seite neuladen?

Ansonsten kann ich gern über Kommandozeile ein Upgrade anstoßen.

Liebe Grüße

That means in English:

I don’t have any influence to that. But I can run the uprade manually for you.

Disabled all not official apps. But no update available.

App list:

Asked again the admin. His answer:


nein, das liegt nicht an einer Firewall, sondern an den Nextcloud Update Servern selbst. Die registrieren manchmal das Update nicht. Auf meinen eigenen Plattformen auf dem Server läuft das Update bereits - ich habe es auch ganz normal über die Oberfläche gemacht, d.h. hier kann nichts blockiert werden.

Ich kann dir gern anbieten, das einfach über die Konsole einzuspielen, aber ansonsten habe ich keinerlei Einfluss darauf.

Liebe Grüße

seems one customer of mine is running into same problems: He does not see an update. all mentioned solutions (switching channels, deactivating apps) are applied with no success. what to do?