[SOLVED] Update NC15 --> NC16.0.3: "Step 6 is currently in process. Please reload this page later."

Support intro

Hey guys
I’m trying to update from NC15 to NC16. When I try to open the updater, the following message appears:

Step 6 is currently in process. Please reload this page later.

There is no more information thatn that. When I access the protocol over the webui, there’s no new messages (last ones are from 3 months ago).
Anybody an idea why it is stuck?

Nextcloud version: 15 --> 16.0.3
Operating system and version: FreeNAS 11.2
Apache or nginx version: 2.4
PHP version: 7.2

Is this the first time you’ve seen this error?: Y

Steps to replicate it:

  1. Open WebUI
  2. Start updater

I had this happen on step 3. Now, step 3 I think is a bit safer since it was only the step of downloading the update. Since you’re on FreeNAS, I assume this is in a jail? Also, did you take a snapshot BEFORE you ran the updater? Either way, make backups of your data and once the backups are done, I would suggest a snapshot.

Maintenance mode off, then go to the directory where you store your data and find the updater-oc*** and appdata-oc*** directories and remove those. Finally, run the updater from the command line:

sudo -u www php /path/to/nextcloud/updater/updater.phar

Should all work after that. If not, rollback to your snapshot of your previously known working state before you did this work.

1 Like

thanks, I will try asap! :slight_smile:

Really appreciated man!

well it worked but after some more I completely destroyed my NC installation :wink: now a re-install is needed.

Anyway, thanks again!