[Solved] Update from 13 to 14 failed!

Hi

I was running till now NextCloud 13 (not sure exactly which minor release) and decided today to do the web update to version 14 (stable branch). As I did previously I did it through the web installer (logged with admin account), it went pretty fine up to the last step asking if it had to stay in maintenance mode (for CLI) or come back online ! I selected to be back online but since NextCloud is no more accessible ! All apps indicate my Nextcloud is in maintenance mode. Web interface gives me that basic error message:

Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

  • Remote Address: my public IP adress here
  • Request ID: AdcBEH4Z4JmYysZNujfP

Error log of web server (Apache) indicates absolutely nothing and access logs contain only that that looks to be nextcloud clients trying to synchronise with it:

myip - - [30/Oct/2018:09:10:07 +0100] “GET /status.php HTTP/1.1” 200 5221 “-” “Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)”
myip - - [30/Oct/2018:09:10:07 +0100] “PROPFIND /remote.php/dav/files/vincen/ HTTP/1.1” 503 1042 “-” “Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)”
myip - - [30/Oct/2018:09:10:14 +0100] “GET /status.php HTTP/1.1” 200 5216 “-” “Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)”
myip - - [30/Oct/2018:09:10:14 +0100] “PROPFIND /remote.php/dav/files/vincen/ HTTP/1.1” 503 1042 “-” “Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)”

Server running on Ubuntu 16.04.2 and Apache 2.4.18 and MySQL 5.7.24

Content of my config.php file (hided all sensible details in it !).

<?php
$CONFIG = array (
  'instanceid' => '123456789',
  'passwordsalt' => '3+xgrihnuesuieaear',
  'secret' => '123456789',
  'trusted_domains' => 
  array (
    0 => 'mydomainnextcloudhere',
  ),
  'datadirectory' => '/home/orn6hon4i5ph/domains/mydomain/data',
  'overwrite.cli.url' => 'http://mydomain',
  'dbtype' => 'mysql',
  'version' => '13.0.2.1',
  'dbname' => 'group',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'dbuserhere',
  'dbpassword' => 'dbpasshere',
  'logtimezone' => 'UTC',
  'installed' => true,
  'mail_from_address' => 'info',
  'mail_smtpmode' => 'sendmail',
  'mail_domain' => 'mydomain',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'mysql.utf8mb4' => true,
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'mysmtpserver',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpport' => '25',
  'mail_smtpname' => 'smtp username',
  'mail_smtppassword' => 'smtp password',
  'updater.release.channel' => 'stable',
  'enabledPreviewProviders' => 
  array (
    0 => 'OC\\Preview\\Image',
    1 => 'OC\\Preview\\MP3',
    2 => 'OC\\Preview\\TXT',
    3 => 'OC\\Preview\\MarkDown',
    4 => 'OC\\Preview\\Epub',
    5 => 'OC\\Preview\\FB2',
    6 => 'OC\\Preview\\PDF',
    7 => 'OC\\Preview\\OpenDocument',
    8 => 'OC\\Preview\\StarOffice',
    9 => 'OC\\Preview\\MSOfficeDoc',
    10 => 'OC\\Preview\\MSOffice2003',
    11 => 'OC\\Preview\\MSOffice2007',
  ),
  'updater.secret' => 'updatersecretkey.',
);

Any ideas what to check to know origin of problem ??

Thanks

Vincèn

Well finally found solution pretty easily and was due to bookmarks app issue found here explained in other threads :wink:
Just in case it might help other people with same issue:

sudo -u webapacheuser php occ app:disable bookmarks

(to do at root directory of your Nextcloud installation)

sudo -u webapacheuser php occ upgrade

(to finish the aborted upgrade process !
and then your NextCloud should be back online :wink:
If you get a warning in NextCloud admin about some missing database headers you can run that last command before closing your terminal:

sudo -u webapacheuser php occ db:add-missing-indices

and you’ll be done for upgrade process from Nextcloud 13 to 14 :smiley:

Vincèn