[solved] Too many certificates error when trying to enable https on NC Box

When I run the nextcloud.enable-https -d script it says all is fine. Then when I run the nextcloud.enable-https to configure https I get this error. I have tried twice with the same result. Is the problem to do with mooo.com domain or is it a problem on my machine? Last line of the log file with the error below.

2017-01-15 12:19:28,038:DEBUG:acme.client:Received response <Response [429]> (headers: {'Content-Length': '152', 'Boulder-Request-Id': 'Y6yA8-pAy7Ga2s1vtqrEn7
Lbd8jF8f6CnWZZFn4bi3I', 'Expires': 'Sun, 15 Jan 2017 12:19:28 GMT', 'Server': 'nginx', 'Connection': 'close', 'Cache-Control': 'max-age=0, no-cache, no-store'
, 'Pragma': 'no-cache', 'Boulder-Requester': '8327843', 'Date': 'Sun, 15 Jan 2017 12:19:28 GMT', 'Content-Type': 'application/problem+json', 'Replay-Nonce': '
yjGnK1ouulFY0aAih7HtjfeCknP_b_peJC2K_Jcyukk'}): '{\n  "type": "urn:acme:error:rateLimited",\n  "detail": "Error creating new cert :: Too many certificates alr
eady issued for: mooo.com",\n  "status": 429\n}'
2017-01-15 12:19:28,045:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
  File "/snap/nextcloud/550/bin/certbot", line 11, in <module>
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/main.py", line 776, in main
    return config.func(config, plugins)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/main.py", line 563, in obtain_cert
    action, _ = _auth_from_domains(le_client, config, domains, lineage)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/main.py", line 100, in _auth_from_domains
    lineage = le_client.obtain_and_enroll_certificate(domains)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/client.py", line 281, in obtain_and_enroll_certificate
    certr, chain, key, _ = self.obtain_certificate(domains)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/client.py", line 263, in obtain_certificate
    return (self.obtain_certificate_from_csr(domains, csr, authzr=authzr)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/certbot/client.py", line 234, in obtain_certificate_from_csr
  File "/snap/nextcloud/550/lib/python2.7/site-packages/acme/client.py", line 312, in request_issuance
    headers={'Accept': content_type})
  File "/snap/nextcloud/550/lib/python2.7/site-packages/acme/client.py", line 649, in post
    return self._check_response(response, content_type=content_type)
  File "/snap/nextcloud/550/lib/python2.7/site-packages/acme/client.py", line 565, in _check_response
    raise messages.Error.from_json(jobj)
Error: urn:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new cert :: Too many certificates already issued for: mooo

The problem was the mooo.com domain. I was using freedns.afraid.org who owns mooo.com and it appears not to work with letsencrypt service on the NC Box. I have used noip.com and that worked first time.