[SOLVED] Some pages get http instead of https after NC15 migration

Nextcloud version 15.0.2:
Operating system and version Debian 4.8:
Apache version 2.4.10 :
PHP version 7.0.33:
Is this the first time you’ve seen this error? Yes only seen after upgrade to 15.0.2 from 14.0.4:

i just upgraded my NC server this evening from 14.0.4 to 15.0.2.
After the upgrade and a server’s reboot, i’m facing an issue :
-When i’m logged in and i click on the NC icon on the top left corner, i have the following error message :

Not found
The requested URL /nextcloud/index.php/apps/files/ was not found on this server.

I host my NC instance at home and i use forced HTTPS with let’s encrypt certificate to access.
I have HAPROXY installed on another VM that forwards my https stream to NC when the url ends with /netxcloud

Globally i can still use my server (webdav/webcal/Windows NC client services are still active and operational) but i have the same issue with some (not all) other webpages under my NC instance like :

  • when trying to disconnect web session
  • when trying to access to index.php within URL

But i have no problem to access subfolders in the file tree or access to plugins as calendar, tasks etc etc

When the error pops up, i can add HTTPS prefix to the remainning URL and the webpage displays correctly.
It’s like the server is forwarding to a non https path and denies access.
I’ve never faced this issue with any preceding version of NC.

Can someone give me some clues to solve this issue?


Problem solved.
It was a bug introduced with 15.0.2 solved here :
Redirecting bug since 15.0.2 #13713

I commented out the cli.url line and replaced it with 'overwritehost' => 'XXXX.de', 'overwriteprotocol' => 'https',

then i restarted Apache and everything is beautiful again :slight_smile: