[solved] Setup NexcloudServer and Android-PhoneTrackApp doesn't work

I need some help on my setup.
I am using my own nextcloud server with app PhoneTrack-Server-App 0.6.2.
On my Android phone I have phoneTrack V0.0.10.

I created a TrackingSessin on my server and I created a “New PhoneTrack log job” selecting the one I created on my server. I seems to work, also I get toast-messages tell me “sessions synchronized”. The Android App also tells me e.g. 136 locations sent, …

But, I cannot see any point in my server log “Impossible to zoom, there is no point to zoom on for this session”.

I am ‘confused’, …



Do you have access to your server’s Nextcloud database? If yes, you can check if the points were actually stored with this SQL query:

select count(*) from oc_phonetrack_points;

If the points are there (in the DB) then it’s an interface problem. First let’s consider this is not a bug (I hope): Did you enable point filtering in the user interface? Did you change any setting at all? Just to be sure: Did you enable the session and do you see the device name in the session area in the sidebar? Did you hit “reload” in user interface option? Or did you try to reload the page?

Many reasons are possible for you problem…

Dear eneiluj,
it took me a while to get phpmyadmin onto my docker. I can confirm that the Adroid-Client did send points into my oc_phonetrack database.
And yes, I changed and played around a lot to find out…
A) Filter was set :frowning: I removed
B) Statistics I see 386 points with avg speed and max speed (but no distance, …)
c) I used " Minimum distance to cut between two points" - as I read something in some forum - and voila: IT WORKS

Basically it would be great if there would be a switch to “reset all frontend parameters to default”.

Anyway: you helped a lot: THANK YOU VERY MUCH!