[Solved] Samba External Storage Writing Forbidden

So, first, a little background of my system:

  1. ESXI Hypervisor as the Main OS of the system.
  2. TrueNAS 12.0U7 installed on a VM handling 32TB of storage
  3. Ubuntu Server 20.04 installed on another VM handling my “website”

In TrueNAS, I have a NFS Share setup exclusively for NextCloud data folder, and an SMB Share setup accessible from my Windows Desktop

The NFS Share is working, accessible, and writable, so I’m not going to talk about that any further.

in my Fstab file, for the SMB share, I have:
//XXX.XXX.XXX.XXX/Windows /var/www/nextcloud/WindowsShare cifs username=XXXXX,password=XXXXX 0 0

I can access my SMB share inside the Ubuntu VM normally, and i can READ the contents inside NextCloud, but i get a popup that says Forbidden when I try to write a file.

Before mounting the file, I did chown and chmod on the mounting point, using www-data and 770 respectively… as soon as i add the entry in fstab and mount -a, the permissions shown on ls -la changes to root:root

Alternatively to the mounting point shown in the fstab line, I have tried /var/www/WindowsShare, /mnt/WindowsShare, and just /WindowsShare, all to no avail

In Nextcloud itself, while adding the share in the Admin Settings, I get a green circle with a checkmark… but when I go to the User Settings, I get a Red Circle when i hit the “apply” button, and then if I click the red circle, it turns green… but when I hit apply again, it goes back to red.

Also in the Administration settings, I have both my User and Admins set as users.

After crawling the forums and google for similar posts and nothing working, hopefully making my own post will help find a solution.

Let me know if any more info is needed,
Thank You

Solved: Instead of mounting the Samba Share in fstab, I learned i was able to load the samba share through the Nextcloud UI.