[solved] Richdocuments 3.2.0 breaks mobile editing

#1

Nextcloud: 15.0.4
Richdocument App: 3.2.0
Code: latest version
Android App: 3.5.0

I manage two instances. Since the 3.2.0 update, on both instances, mobile live editing doesn’t work anymore. It shows the document icon and name, and the loading indicator. It runs like this indefinitely.

I can only see error for the android app:

02-14 10:57:06.299  3671  4483 I ActivityManager: Start proc 30597:com.android.chrome:sandboxed_process3/u0i120 for webview_service com.nextcloud.client/org.chromium.content.app.SandboxedProcessService3
02-14 10:57:06.697 30597 30624 I chromium: [INFO:library_loader_hooks.cc(42)] Chromium logging enabled: level = 0, default verbosity = 0
02-14 10:57:06.989 26316 26316 I chromium: [INFO:CONSOLE(7)] "JQMIGRATE: Migrate is installed, version 1.4.0", source: https://mydomain.com/nextcloud/core/vendor/core.js?v=aa1dfbab-18 (7)
02-14 10:57:07.161 26316 26316 I chromium: [INFO:CONSOLE(3711)] "Deprecation warning: tipsy is deprecated. Use tooltip instead.", source: https://mydomain.com/nextcloud/js/core/merged-template-prepend.js?v=aa1dfbab-18 (3711)
02-14 10:57:07.168 26316 26316 I chromium: [INFO:CONSOLE(548)] "Waiting for page to render…", source: https://mydomain.com/nextcloud/apps.installed/richdocuments/js/documents.js?v=aa1dfbab-18 (548)
02-14 10:57:07.172 26316 26316 I chromium: [INFO:CONSOLE(841)] "Uncaught TypeError: parent.OCA.Files.App.fileList.reload is not a function", source: https://mydomain.com/nextcloud/apps.installed/richdocuments/js/documents.js?v=aa1dfbab-18 (841)
02-14 10:57:07.238 26316 26316 I chromium: [INFO:CONSOLE(0)] "Failed to decode downloaded font: https://mydomain.com/nextcloud/core/fonts/Nunito-Regular.woff2", source: https://mydomain.com/nextcloud/apps/richdocuments/direct/MYGzKD3prIp0Ya5e9INbTSaHDDU3johbwVxg0dP1bxyCa6wh6BNaKrUvVOta9cnS (0)
02-14 10:57:07.238 26316 26316 I chromium: [INFO:CONSOLE(0)] "OTS parsing error: invalid version tag", source: https://mydomain.com/nextcloud/apps/richdocuments/direct/MYGzKD3prIp0Ya5e9INbTSaHDDU3johbwVxg0dP1bxyCa6wh6BNaKrUvVOta9cnS (0)
02-14 10:57:08.005 26316 26316 I chromium: [INFO:CONSOLE(22)] "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.", source: https://mydomain.com/loleaflet/bdf2f61/bundle.js (22)
0 Likes

#2

It is fixed in master: https://github.com/nextcloud/richdocuments/commit/d8f8f5928685ff413e46be925b6fcfd266556efa

0 Likes

#3

So should this be fixed in 3.2.2? For me Collabora works fine on the Web page but mobile editing does not load

0 Likes

#4

Seems like we have some kind of regression. It worked in 3.2.1 but not in 3.2.2 ( i need to double check this)

0 Likes

#5

That was a strange one. It did not work on my system with latest nextcloud and richdocuments and collabora online. I downgraded to richdocuments 3.2.1 it started working again. After a few tests i upgraded back to 3.2.2 and it continued working.

0 Likes

#6

Could you explain how you downgrade? Remove the old app, download/unpack/chmod the old package and activate it in the Web GUI or some other way?

0 Likes

#7

I did pretty much what you described.

0 Likes

#8

And yes it seems like it is a regression. Since 3.2.2 it stopped working again.

0 Likes

#9

A fix is in the repo so it will work again next release

0 Likes

#10

Thanks, good to know

0 Likes