[Solved] Only Office has stopped working

Hi,

A few weeks ago my Only Office app stopped working. When trying to open a document it just hangs on the loading screen. When I first noticed this a few weeks ago I also saw that I need to update the Community Document Server so I thought that this might be causing the issue but when I tried to update to the new version I found that I couldn’t update the Community Document Server. so I manually downloaded the updated package to the apps folder and updated from there. This did not solve the problem and now when I save the server settings in Only Office setting I get this error:

Error when trying to connect (cURL error 60: SSL: no alternative certificate subject name matches target host name ‘192.168.1.205’ (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)) (version 5.4):heavy_multiplication_x:

I have un-installed and re-installed the Community Document server and OnlyOffice using the occ command but the problem persists. As at test I tried to connect to the Demo server and got this error:

Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 5.4)

I am completely lost and going round in circles. Can someone help please.

Thanks.

Nextcloud version 18.07
Operating system Ubuntu 20.04
nginx version _1.19.1
PHP version _ 7.4.8

I do not use it. But perhaps you can test this beginning with:

If you are using a self-signed certificate for …

https://api.onlyoffice.com/editors/nextcloud

Thanks Devnull,

I’m not using a self signed certificate . I’m using a certificate from Lets Encrypt but I tried this mod for self signed certificate anyway. But unfortunately, It didn’t work.

Ok. But in the error message something get work. In your last log the names differ and there is perhaps a problem with the certificate or the name. Test your virtual webservers and the configurations of your services.

Hi devnull,

I’m fairly new to this. How would I test my virtual webservers and the configurations of your services?

I’ve solved my issue. I had logged into my Nextcloud admin account via my Lan address as I was working within my own network. As soon as I logged in using my Nextcloud server domain name address I was able to save the server settings and the error dissapeared . OpenOffice is working now.